MINI Cooper Forum - View Single Post - IMPORTANT. Have you had a power steering pump failure? Please vote YES or NO!!!
Go Back   MINI Cooper Forum


Mini2.com is the premier Mini Cooper Forum on the internet. Registered Users do not see the above ads.
View Single Post
  #1057 (permalink)  
Old Oct 31st, 2012, 09:43 AM
coopergti
MINI2 Newbie
Offline
 
Join Date: Aug 2006
Posts: 6
Local Time: 07:34 AM
Greece View coopergti's Classified Ads
Mine just failed on a 11/04 with almost 64k miles. I had 2-3 failures a few months ago but with stop and start again the car the problem fixed for that time. Yesterday the pump didn't stop to run even with the ignittion off so I disconnected the battery. So, at the momment I know that the pump is still working but not properly. I have read from this thread that a good cleaning might help and I am going to give it a try. But I would like if anybody knows to tell me what kind of brushes am I going to need in order to change them also. If you have a part number also would be great.
Reply With Quote
 
» Recent Threads
I need a tool to flash a JCW map to my 04 MCS ECU
Yesterday 09:42 PM
Last post by djtmalta
Yesterday 10:36 PM
2 Replies, 131 Views
LED Daytime running lights - retro fit
Apr 15th, 2014 06:08 PM
Last post by french01
Yesterday 09:17 PM
6 Replies, 1,400 Views
Electric window stopped working
Jul 6th, 2006 03:48 PM
Last post by regarp
Yesterday 06:22 PM
34 Replies, 65,936 Views
Bonnet touching body
Aug 15th, 2014 03:47 PM
Last post by The Nun
Yesterday 03:58 PM
3 Replies, 446 Views
Facebook page selling mini parts around the uk
Yesterday 11:50 AM
by Alex93x
Last post by Restyle
Yesterday 03:25 PM
2 Replies, 134 Views
New Mini Cooper D - Worth the money?
Yesterday 01:33 PM
Last post by dangoodwin
Yesterday 01:33 PM
0 Replies, 121 Views
Mini Clubman Barn Doors Won't Lock
Oct 22nd, 2014 03:51 AM
Last post by WeeBad
Yesterday 01:03 PM
3 Replies, 424 Views
R56 Footwell module dead
Jul 15th, 2014 04:19 AM
by miniuy
Last post by k3fus
Yesterday 07:16 AM
6 Replies, 1,287 Views
inside lights
Oct 23rd, 2014 11:19 PM
Last post by bigmamabear
Oct 23rd, 2014 11:19 PM
0 Replies, 178 Views
Lights on warning not working
Oct 21st, 2014 11:42 AM
by S2dicky
Last post by S2dicky
Oct 23rd, 2014 09:16 PM
4 Replies, 479 Views
Smoked Headlight Covers GTO276S
Oct 23rd, 2014 08:49 PM
by tmath23
Last post by tmath23
Oct 23rd, 2014 08:49 PM
0 Replies, 181 Views
engine fan on more frequently
Oct 16th, 2014 01:46 PM
Last post by stewarth
Oct 23rd, 2014 07:27 PM
3 Replies, 657 Views
Cooper S judders when idle...
Jul 17th, 2010 04:53 PM
by ben_uk
Last post by Restyle
Oct 23rd, 2014 06:18 PM
6 Replies, 1,123 Views
R56 Aux input volume???????
Oct 20th, 2014 04:00 PM
Last post by Dermottdog
Oct 23rd, 2014 06:00 PM
4 Replies, 571 Views
Start/Stop engine button illuminated when car is locked
Oct 21st, 2014 08:07 PM
Last post by The Nun
Oct 23rd, 2014 05:03 PM
6 Replies, 568 Views
Wheel arch - advice please :)
Oct 22nd, 2014 10:08 PM
Last post by The Nun
Oct 23rd, 2014 05:00 PM
2 Replies, 266 Views
No spray on windshield wiper
Oct 19th, 2014 08:54 PM
by mom7x
Last post by CCroker
Oct 23rd, 2014 01:57 PM
2 Replies, 458 Views
Will I get jipped?
Oct 21st, 2014 11:14 PM
Last post by CCroker
Oct 23rd, 2014 01:52 PM
3 Replies, 396 Views
Rear wiper motor stem problem
Oct 18th, 2014 09:57 AM
Last post by ihughes
Oct 23rd, 2014 01:34 PM
4 Replies, 585 Views
2010 Cooper S
Oct 23rd, 2014 01:13 PM
Last post by mike_1979
Oct 23rd, 2014 01:13 PM
0 Replies, 227 Views
» Premium
» Auto Insurance
Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.1

All times are GMT. The time now is 05:34 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.