Bizarre Horn problem. - MINI Cooper Forum

First Generation Faults & Fixes MINI faults and fixes 2001 - 2006

User Tag List

 
LinkBack Thread Tools Rate Thread
post #1 of 2 (permalink) Old May 23rd, 2014, 02:25 PM Thread Starter
MINI2 Newbie
 
Join Date: May 2014
Local Time: 01:06 PM
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

United Kingdom
 
Bizarre Horn problem.

Hello guys,

I really need your help, I have spent too much money and the horn is still not fixed.

Basically the horn buttons don't work, so we changed the fuses still nothing, so we changed the actual horns as we thought they may be broke so we ordered new ones but still nothing. So then I bought a new rotary wheel for the steering wheel, but still nothing. We thought due to the age the fuse box may have broke or something bizarre like that so I ordered a new fuse box with all fuses etc... still nothing.. at this point we tested the wires, if we squashed one of the relays or the fuse the horn will go off, so the fuses and horn its self works fine except the buttons. So we tested the wires coming off the steering wheel and they were giving signs it was working so we tested the cables on the rotary wheel while plugged in, but they weren't giving any signs so at this point we thought we ordered a broken rotary wheel so we bought another one... but still it doesn't work.

Please help, i dont know what else to try i am getting fed up.

Thank you.
acid2k1 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old May 23rd, 2014, 06:57 PM
MINI2 Privilege Member
MINI2 Master
 
Join Date: Mar 2012
Local Time: 01:06 PM
Posts: 3,400
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)

United Kingdom Male
 
As youve tested or renewed everything else it sounds like an earthing fault??
Find the earthing point for the horns, and check its clean and secure, on the Gen 2 models its somewhere near the back of the offside headlight.

Yours is a Gen 1 though, might be in a similar area?
The Nun is online now  
Sponsored Links
Advertisement
 
Reply
Tags: , , ,


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the MINI Cooper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 Mini Cooper S - No start problem Wintersroadshow First Generation Faults & Fixes 2 Mar 21st, 2014 03:58 PM
Intermittent sound problem with IPOD and AUX inputs dsmith Second Generation Interior & Ice 3 Jan 22nd, 2014 09:30 AM
Horn Sounds on its own. Triumph fan First Generation Faults & Fixes 2 Jun 3rd, 2013 01:21 PM
Mini problem - please help!! HelpMe General Discussion 13 Jan 18th, 2013 10:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome