Dashboard lights come on when radio turned on - MINI Cooper Forum

First Generation Interior & Ice
Find Sponsor products associated with this forum
First generation MINI interior 2001 - 2006

User Tag List

 
LinkBack Thread Tools Rate Thread
post #1 of 6 (permalink) Old Mar 16th, 2010, 06:38 PM Thread Starter
MINI2 Newbie
 
Muttzcuttz's Avatar
 
Join Date: Mar 2009
Local Time: 07:19 PM
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

United Kingdom
 
Red face Dashboard lights come on when radio turned on

Hey guys and girls

I've had a search but couldnt find anything that matched the issue I'm having, and forgive me, but Im a bit of a noob with wiring!

I replaced the head unit in my MINI with a SONY CDX-GT620U, used standard ISO converters to fit it, great!

However, when the radio is in standby (ignition on) all is normal, as soon as I press power on the head unit, the dashboard lights come on, the orange ones that illuminate the speedometer and the rev counter

I dont remember this happening with my old head unit

Other than the dash lights coming on, everything else is fine, it seems to have a constant 12V as it remembers the presets and the time when the ignition is turned off.

While I'm here, the cage doesn't seem particularly secure, I cant bend the tabs in it properly because of the 'ledge' where the mini head unit rested

Any ideas much appreciated, thanks!
Muttzcuttz is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Mar 22nd, 2010, 03:15 PM
MINI2 Senior
 
chris.lamb's Avatar
 
Join Date: Oct 2004
Location: Warwick
Local Time: 06:19 PM
Posts: 727
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

United Kingdom Male View chris.lamb's Chili Red & White 1st Gen MINI Cooper S Profile
 
The ISO connector is wired incorrectly and the head unti is feeding 12V to the illumination wire for the instruments that usually feeds voltage to the radio for its backlight.
chris.lamb is offline  
post #3 of 6 (permalink) Old Mar 22nd, 2010, 06:34 PM Thread Starter
MINI2 Newbie
 
Muttzcuttz's Avatar
 
Join Date: Mar 2009
Local Time: 07:19 PM
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

United Kingdom
 
Sorry for sounding dumb, I've checked and the only wires going into the back of the head unit are as follows (I've written down the label on the wires and the colours, i dont know what is needed, they seem to match to me. Can I just remove the illumination / dash light or will this stop the backlight on the unit working??

Sony Head Unit > ISO cable

1
2
3
4 +12v constant - yellow
5 power antenna - blue
6 amp turn on +12v - blue/white
7 +12v ignition switched - red
8 chassis ground 12v- - black


These match the following cables on the MINI head unit harness adapter

1
2
3
4 +12v constant - yellow
5 left rear +ve - blue
6 illumination / dash light - orange
7 ignition / switched 12v+ - red
8 chassis ground 12v- - black



I'm a bit confused. I don't want to wire something the wrong way in case things go bang
Muttzcuttz is offline  
post #4 of 6 (permalink) Old Mar 24th, 2010, 10:25 AM
MINI2 Senior
 
chris.lamb's Avatar
 
Join Date: Oct 2004
Location: Warwick
Local Time: 06:19 PM
Posts: 727
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

United Kingdom Male View chris.lamb's Chili Red & White 1st Gen MINI Cooper S Profile
 
so you have got amp turn on wired to illumination!
thus the radio tries to turn on the amp and instead turns on the cars backlight illumination!
disconect this wire
chris.lamb is offline  
post #5 of 6 (permalink) Old Mar 24th, 2010, 10:38 PM
MINI2 Master
 
SteveM3's Avatar
 
Join Date: Dec 2002
Location: Malmesbury, Wilts
Local Time: 07:19 PM
Posts: 2,160
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)

England Male View SteveM3's Spice Orange & Body Color 2nd Gen MINI Cooper S Profile
 
Chris is correct. It seems strange the Sony has so few connections, how does it know when you switch the lights on so it can dim the display. Also look for a white wire in your Mini's original wiring, this is for the amp of the aerial. You can connect the amp turn on blue/white to this. It seems a common problem with these ISO convertors that they miss out the aerial amp connection.

Some people are like a Slinky ........ not really good for anything, but you still can't help
but smile when you shove them down the stairs
SteveM3 is offline  
post #6 of 6 (permalink) Old Apr 17th, 2010, 01:09 PM Thread Starter
MINI2 Newbie
 
Muttzcuttz's Avatar
 
Join Date: Mar 2009
Local Time: 07:19 PM
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

United Kingdom
 
Thanks for the help so far.
I ordered a new 16pin cable as I was getting nothing with the old one (no power at all, nothing).
Now I have the new one, only the main unit has power, the flip down fascia has no power and no display. The buttons do nothing, but the main unit is happy to accept and eject CDs

Any ideas? I should have just stayed with my original MINI unit
Muttzcuttz is offline  
Sponsored Links
Advertisement
 
Reply
Tags: , , , ,


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MINI Cooper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dashboard lights not working? AlanB11 General Discussion 12 Dec 1st, 2013 11:06 PM
Help! Dashboard lights going crazy! daniel.w.leigh Second Generation Faults & Fixes 7 Apr 4th, 2013 11:30 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome