New owner problems - MINI Cooper Forum

First Generation MINI Cooper S MINI Cooper S 2002 - 2006

 2Likes
  • 1 Post By SeanC
  • 1 Post By JohnnyC
 
LinkBack Thread Tools Rate Thread
post #1 of 9 (permalink) Old Jan 11th, 2017, 07:31 PM Thread Starter
MINI2 Regular
 
Sasquatchuk's Avatar
 
Join Date: Jan 2017
Local Time: 08:13 PM
Posts: 92
Mentioned: 1 Post(s)
Quoted: 14 Post(s)

 
England New owner problems

Bought my cooper s 2003 on Christmas eve. was a tidy but had a few problems. First problem is a xenon light that randomly goes out I have to switch them on and of on the stalk. Second problem and worse was that the heater was giving no heat. The engine as not overheating or using any coolant that I could see. So I tried to bleed the system I got a lot of air out but still no heat. It was then I drained the system and removed the thermostat it was then I spotted the copper particles of K seal. This meant to me suspect head gasket. So I ordered the parts and stripped it down. I have flushed all the water system through now and have clean water. I could not spot any clear blown parts on the gasket but see copper particles around a couple of water jackets. I have also ordered thermostat and housing. I also had to remove the sump as a friend accidently dropped a socket down the cam chain housing into the sump. Next time I will deffo block the area off with a rag . I have since cleaned the sump out and removed the pickup cleaned and replaced the seal no nasty surprises where found in the sump the engine seems to have plenty of life left in her thank goodness.
I guess my matrix was filling with air hence why I received no heat. Any tips on bleeding these. I have checked the supercharger is driving the pump. And next time intend on taking it off and checking it properly whilst fitting a new pump oil change and smaller pulley.
I have driven the car 2 days in total so cant wait to get it on the road.
if anyone has any tips on sorting the headlamp let me know.
Cheers

heres hoping to having a running car on sunday with heat!!!

Sasquatchuk is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old Jan 11th, 2017, 08:08 PM
MINI2 Master
 
Join Date: Dec 2013
Local Time: 08:13 PM
Posts: 3,981
Mentioned: 20 Post(s)
Quoted: 751 Post(s)

United Kingdom
 
The matrix could very well be blocked if it's had gunk in it!

Milpol likes this.
SeanC is online now  
post #3 of 9 (permalink) Old Jan 12th, 2017, 07:00 AM Thread Starter
MINI2 Regular
 
Sasquatchuk's Avatar
 
Join Date: Jan 2017
Local Time: 08:13 PM
Posts: 92
Mentioned: 1 Post(s)
Quoted: 14 Post(s)

 
I have flushed the matrix through and it runs clean now have run a hose through the whole system a few times. Hopefully fingers crossed it will be sorted
Sasquatchuk is offline  
 
post #4 of 9 (permalink) Old Jan 12th, 2017, 08:46 AM
MINI2 Master
 
Join Date: Dec 2013
Local Time: 08:13 PM
Posts: 3,981
Mentioned: 20 Post(s)
Quoted: 751 Post(s)

United Kingdom
 
Keep us updated buddy. Fingers crossed
SeanC is online now  
post #5 of 9 (permalink) Old Jan 12th, 2017, 07:10 PM
MINI2 Master
 
JohnnyC's Avatar
 
Join Date: Oct 2011
Local Time: 08:13 PM
Posts: 848
Mentioned: 19 Post(s)
Quoted: 155 Post(s)

United Kingdom
 
You said you've ordered a thermostat, have you received and fitted it yet?
JohnnyC is online now  
post #6 of 9 (permalink) Old Jan 12th, 2017, 08:10 PM Thread Starter
MINI2 Regular
 
Sasquatchuk's Avatar
 
Join Date: Jan 2017
Local Time: 08:13 PM
Posts: 92
Mentioned: 1 Post(s)
Quoted: 14 Post(s)

 
Got all the parts here ready to fit weekend. Thermostat housing gaskets and sump all cleaned as well as pickup. Hoping after all this it runs better and with heat it's so cold in UK at moment without heating .Bought a tool belt and belt as well thought might as well change that as well . So at the moment I have mini in pieces .
Sasquatchuk is offline  
post #7 of 9 (permalink) Old Jan 12th, 2017, 08:10 PM Thread Starter
MINI2 Regular
 
Sasquatchuk's Avatar
 
Join Date: Jan 2017
Local Time: 08:13 PM
Posts: 92
Mentioned: 1 Post(s)
Quoted: 14 Post(s)

 
Anyone have any ideas on the xeon light? Problem
Sasquatchuk is offline  
post #8 of 9 (permalink) Old Jan 12th, 2017, 09:11 PM
MINI2 Master
 
JohnnyC's Avatar
 
Join Date: Oct 2011
Local Time: 08:13 PM
Posts: 848
Mentioned: 19 Post(s)
Quoted: 155 Post(s)

United Kingdom
 
Swap the bulbs over, that way you'll know if it's the bulb or the ballast.
SeanC likes this.
JohnnyC is online now  
post #9 of 9 (permalink) Old Jan 16th, 2017, 03:58 PM Thread Starter
MINI2 Regular
 
Sasquatchuk's Avatar
 
Join Date: Jan 2017
Local Time: 08:13 PM
Posts: 92
Mentioned: 1 Post(s)
Quoted: 14 Post(s)

 
Update.

Head back on.. sump back on. Tried to turn over without ht leads but it would not turn over till I plugged the leads in. still waiting on new heater matrix to be deliviered. Had engine running today but Eml light was flashing so need connect my laptop to read Codes.

It's a mini.adventure .

Still no heat though hence why I'm changing the matrix. Oh well eventually I will have a new mini
Sasquatchuk is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MINI Cooper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
PANORAMIC SUN ROOF ISSUES -I'm in talks with Mini Head Office UK PLEASE READ/CONTACT LadyUK General Discussion 63 Oct 8th, 2015 05:56 PM
New owner problems zenman63 First Generation MINI Cooper S 2 May 21st, 2015 03:01 PM
1st time Mini Owner - Some Problems with her though izaakH Welcome New Members 3 Apr 30th, 2015 11:02 AM
new member new owner big problems nics86 Welcome New Members 1 Mar 15th, 2015 12:39 AM
New owner couple of problems Keithys Maintenance & MINI Care 2 Apr 29th, 2014 07:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome