Replaced rear brakes now issues with wear pattern - MINI Cooper Forum
Go Back   MINI Cooper Forum > All Models & Variants > General Discussion


General Discussion Use this forum to discuss MINI topics which are not related to other forums. Posts may be moved from here to alternative forums by the moderators without notice

Mini2.com is the premier Mini Cooper Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread
  #1 (permalink)  
Old Feb 17th, 2014, 08:16 PM
MINI2 Newbie
Offline
 
Join Date: Jan 2014
Posts: 3
Local Time: 12:01 PM
United Kingdom
Replaced rear brakes now issues with wear pattern

Hey folks, I replaced the pads and discs on our 08 cooper d this weekend.

Passenger side (uk) was fine no probs. Drivers side was terrible disc retaining bolt / stud was stuck solid drilled it and then snapped a stud remover trying to get it out.

In the end it got dark and wet and had to put the new disk and pads on with no retaining bolt, I'll either need to drill and tap a new hole on the hub or replace the hub.

Anyway all was looking good and did about 40 miles today, brakes felt good and didnt feel any pull etc. When I checked the discs (which are coated with protective paint from new) the passenger side has a nice even band worn in the paint. However the drivers side has only about 15mm worn in the paint towards the top of the disc on the outside.

Any ideas the pads, sliders etc are greased in the right places. Have I over retracted the piston and its jammed? Help!!
Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

» Recent Threads
Facebook page selling mini parts around the uk
Today 11:50 AM
by Alex93x
Last post by Alex93x
Today 11:50 AM
0 Replies, 10 Views
Bonnet touching body
Aug 15th, 2014 03:47 PM
Last post by mpaxton78
Today 09:33 AM
2 Replies, 353 Views
R56 Footwell module dead
Jul 15th, 2014 04:19 AM
by miniuy
Last post by k3fus
Today 07:16 AM
6 Replies, 1,211 Views
Mini Clubman Barn Doors Won't Lock
Oct 22nd, 2014 03:51 AM
Last post by chrysler300
Today 02:42 AM
2 Replies, 354 Views
inside lights
Yesterday 11:19 PM
Last post by bigmamabear
Yesterday 11:19 PM
0 Replies, 110 Views
Lights on warning not working
Oct 21st, 2014 11:42 AM
by S2dicky
Last post by S2dicky
Yesterday 09:16 PM
4 Replies, 444 Views
Smoked Headlight Covers GTO276S
Yesterday 08:49 PM
by tmath23
Last post by tmath23
Yesterday 08:49 PM
0 Replies, 128 Views
engine fan on more frequently
Oct 16th, 2014 01:46 PM
Last post by stewarth
Yesterday 07:27 PM
3 Replies, 618 Views
Cooper S judders when idle...
Jul 17th, 2010 04:53 PM
by ben_uk
Last post by Restyle
Yesterday 06:18 PM
6 Replies, 1,080 Views
R56 Aux input volume???????
Oct 20th, 2014 04:00 PM
Last post by Dermottdog
Yesterday 06:00 PM
4 Replies, 533 Views
Start/Stop engine button illuminated when car is locked
Oct 21st, 2014 08:07 PM
Last post by The Nun
Yesterday 05:03 PM
6 Replies, 508 Views
Wheel arch - advice please :)
Oct 22nd, 2014 10:08 PM
Last post by The Nun
Yesterday 05:00 PM
2 Replies, 235 Views
No spray on windshield wiper
Oct 19th, 2014 08:54 PM
by mom7x
Last post by CCroker
Yesterday 01:57 PM
2 Replies, 430 Views
Will I get jipped?
Oct 21st, 2014 11:14 PM
Last post by CCroker
Yesterday 01:52 PM
3 Replies, 364 Views
Rear wiper motor stem problem
Oct 18th, 2014 09:57 AM
Last post by ihughes
Yesterday 01:34 PM
4 Replies, 557 Views
2010 Cooper S
Yesterday 01:13 PM
Last post by mike_1979
Yesterday 01:13 PM
0 Replies, 181 Views
2001 Mini Cooper - heater not working
Oct 22nd, 2014 08:41 AM
by TreezaB
Last post by TreezaB
Yesterday 07:48 AM
2 Replies, 318 Views
$95 @ Willow Springs Streets of Willow November 15-16 2014
Yesterday 01:37 AM
by harvie
Last post by harvie
Yesterday 01:37 AM
0 Replies, 165 Views
PAS Fluid Leak HELP!!
Oct 15th, 2014 07:16 PM
Last post by mab01uk
Oct 22nd, 2014 10:59 PM
7 Replies, 699 Views
Problem after problem!! Help please!!
Oct 22nd, 2014 08:32 PM
Last post by mab01uk
Oct 22nd, 2014 10:50 PM
1 Replies, 571 Views
» Premium
» Auto Insurance
Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.1

All times are GMT. The time now is 12:01 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.3.2