2003 Mini S light and tach issue - MINI Cooper Forum

General Discussion Use this forum to discuss MINI topics which are not related to other forums. Posts may be moved from here to alternative forums by the moderators without notice

User Tag List

LinkBack Thread Tools Rate Thread
post #1 of 1 (permalink) Old Jul 18th, 2014, 02:25 AM Thread Starter
MINI2 Newbie
Join Date: Jul 2014
Local Time: 02:36 PM
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

United States
2003 Mini S light and tach issue

Mi just got a 2003 Mini Cooper S and I need to do some work rails on the sun roof and all. But what has got me stumped is the #5 fuse under the dash has no power I traced it to he 2 wires on the back of the box neither side has power..

The cause of me looking is, I have no dash lights, no fog lights and no power to my Tachometer. I did check the computer on the right side the unimis dry with no sign of water damage. The amplifier is missing as the person said it was taken before I got the car.

Any help would be great.
The Doctor 42 is offline  
Sponsored Links
Tags: , ,

Quick Reply

Register Now

In order to be able to post messages on the MINI Cooper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome