Brake servo stopped working! - MINI Cooper Forum

General Discussion Use this forum to discuss MINI topics which are not related to other forums. Posts may be moved from here to alternative forums by the moderators without notice

User Tag List

 
LinkBack Thread Tools Rate Thread
post #1 of 1 (permalink) Old Jul 26th, 2014, 02:32 PM Thread Starter
MINI2 Newbie
 
Join Date: Jul 2014
Local Time: 05:36 AM
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

United Kingdom
 
Brake servo stopped working!

Hi all,
I hope you good people on here can help me. The brake servo on my daughter's 2010 R56 Cooper D has stopped working and I was wondering if this was a known problem that somebody here could help me with? The car has covered 56000 miles and I can't here any hissing or sucking noises to suggest maybe a pipe has come loose.

All assistance would be VERY gratefully received.
Joe 90 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mini Cooper brake problem Janie Wheels, Tyres & Brakes 3 Jun 5th, 2014 05:52 PM
Brake lights not working Bigyin1980 First Generation Faults & Fixes 2 Mar 20th, 2014 07:57 PM
Aircon, Rear heated window and Sunroof stopped working williamtell First Generation Faults & Fixes 4 Nov 15th, 2012 09:10 PM
Air con stopped working? MCS-W11NJP Second Generation MINI Cooper S 2 Sep 8th, 2012 06:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome