2007 Mini Cooper S fuel issues - MINI Cooper Forum
Go Back   MINI Cooper Forum > MINI Technical Forums > MINI Faults & Fixes > Second Generation Faults & Fixes


Second Generation Faults & Fixes MINI faults and fixes Late 2006 - Present

Mini2.com is the premier Mini Cooper Forum on the internet. Registered Users do not see the above ads.
Reply
Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 MINI Cooper Hardtop Revealed AutoGuide.com MINI News 13 Dec 12th, 2014 10:39 AM
PANORAMIC SUN ROOF ISSUES -I'm in talks with Mini Head Office UK PLEASE READ/CONTACT LadyUK General Discussion 53 Aug 9th, 2014 01:47 PM
high pressure fuel pump leak and head office lies! Shanos General Discussion 0 Nov 29th, 2013 05:24 PM
Newbie with a 2007 Mini Cooper and a 2010 Mini Cooper S JCW Converible dcphotos Welcome New Members 0 Sep 18th, 2012 01:05 AM

 
LinkBack Thread Tools Rate Thread
  #1 (permalink)  
Old Mar 15th, 2014, 09:12 PM
MINI2 Newbie
Offline
 
Join Date: Mar 2014
Location: staffordshire
Posts: 14
Local Time: 07:52 AM
United Kingdom
2007 Mini Cooper S fuel issues

My daughters mini stopped whilst driving and refused to restart for 10 mins, when it did it would not rev and seemed to be lacking fuel.
I got it home and noticed the fuel pump prime did not occur when inserting the fob to start. Having now removed the rear seat the fuel pump is not running for some reason?? if I get it to start it just cuts out after a few seconds.
I have discounted a High pressure pump fault as the tank pump is not running (no noise) any ideas -a wiring diagram would help.
thanks
Reply With Quote
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old Mar 15th, 2014, 10:04 PM
MINI2 Master
Offline
 
Join Date: Feb 2011
Location: South london
Posts: 1,203
Local Time: 06:52 AM
United Kingdom Male
Hi ya

I think I would check the Fuses or a relay first
Fuse box inside your car fuses f43 20 amp fuel pump relay
The relay it's self is the bottom relay in that fuse box by all the connectors at the bottom.
You can test the fuel pump by removing the relay and putting in a jumping lead between two terminals but I can not remember which ones I think as you look at it 9 and 3 o'clock but don't quote me on that. And it must be fused type of jumper lead

But if you put your hand on it, insert the key fob you should feel it click. Doing it this is not always 100% positive I have had relays click but still are faulty rare but it does happen.
If they are ok you need to check the fuel pump under the back seats and see if you have voltage there I think it the two Centre pins on the plug.
I have seen water and corrosion in the plug so might be with looking at that to


Hope this helps
Reply With Quote
Thanks for this post from:
  #3 (permalink)  
Old Mar 16th, 2014, 12:36 AM
MINI2 Newbie
Offline
 
Join Date: Mar 2014
Location: staffordshire
Posts: 14
Local Time: 07:52 AM
United Kingdom
Hi, thanks for that marque, I will try this tomorrow-I was unsure where the relay was but if looping it out proves the pump thats a good staring point.
I will let you know how things go
thanks
Reply With Quote
  #4 (permalink)  
Old Mar 16th, 2014, 10:51 AM
MINI2 Newbie
Offline
 
Join Date: Mar 2014
Location: staffordshire
Posts: 14
Local Time: 07:52 AM
United Kingdom
update

I have now checked for supply on the 20 amp fuse and its fine, if I remove the bottom relay (fuel pump?)all sorts of funny warning lights come on when I refit it. still no pump prime when I insert the fob,
I was wondering if this is the pump relay as it seems to work other things as well.
Marque-could I try a supply direct to the pump? if so which wires go on what pins and which way round + -?
thanks
john
Reply With Quote
  #5 (permalink)  
Old Mar 16th, 2014, 11:36 AM
MINI2 Newbie
Offline
 
Join Date: Mar 2014
Location: staffordshire
Posts: 14
Local Time: 07:52 AM
United Kingdom
update,
Put a direct supply on to pump + on pin 2(blue/white), - on pin 5(brown), pump runs fine. checked supply on connector to pump and nothing 0v. so its a 12v supply issue.
could someone confirm relay location for fuel pump????I now need to find this,and work out whats going on
thanks john
Reply With Quote
  #6 (permalink)  
Old Mar 16th, 2014, 01:30 PM
MINI2 Premium Member
MINI2 Master
Offline
 
Join Date: Mar 2012
Posts: 3,271
Local Time: 06:52 AM
United Kingdom Male
In the Bentley repair manual for the Gen 2 cars
Fuse for the fuel pump relay is F43 and its a 20amp
And it says the fuel pump relay is,
Quote:
"Junction box fuse and relay panel, right front behind kick panel trim cover. (assume that means in the footwell)
Relay K96 and looks like the relay is on the back of the board at the bottom right
Reply With Quote
  #7 (permalink)  
Old Mar 16th, 2014, 03:41 PM
MINI2 Newbie
Offline
 
Join Date: Mar 2014
Location: staffordshire
Posts: 14
Local Time: 07:52 AM
United Kingdom
fuel pump relay-2007 mini cooper s

Hi gents,
I am unsure were to go from here.
The relay on the front of the board seems to effect airbags etc, so is the fuel pump relay on the board at the back like the earlier R53? I am struggling to get a R56 wiring diagram which is making it worse.
thanks
Reply With Quote
  #8 (permalink)  
Old Mar 16th, 2014, 06:50 PM
MINI2 Premium Member
MINI2 Master
Offline
 
Join Date: Mar 2012
Posts: 3,271
Local Time: 06:52 AM
United Kingdom Male
It would appear its at the back yes, at least thats how it seems to read to me in the manual?
Reply With Quote
  #9 (permalink)  
Old Mar 17th, 2014, 12:27 PM
MINI2 Master
Offline
 
Join Date: Feb 2011
Location: South london
Posts: 1,203
Local Time: 06:52 AM
United Kingdom Male
hi ya

check all your fuses in the engine bay fuse box to

hope these pics help :-)
Attached Files
File Type: pdf 2014-03-17 11-12.pdf (279.1 KB, 37 views)
File Type: pdf 2014-03-17 11-13-04.pdf (357.5 KB, 30 views)
File Type: pdf 2014-03-17 11-14-27.pdf (347.9 KB, 29 views)
File Type: pdf 2014-03-17 11-19-12.pdf (339.8 KB, 28 views)
File Type: pdf 2014-03-17 11-20-45.pdf (309.4 KB, 27 views)
Reply With Quote
  #10 (permalink)  
Old Mar 19th, 2014, 09:37 PM
MINI2 Newbie
Offline
 
Join Date: Mar 2014
Location: staffordshire
Posts: 14
Local Time: 07:52 AM
United Kingdom
Update-I now know that pump does not run until you press the start button!
I was told it runs when you insert fob. Pump runs fine and I now have checked pressure at tank at 5 Bar so that's OK. Starts up and still stalls. very irratic to start.
Reply With Quote
  #11 (permalink)  
Old Mar 20th, 2014, 08:53 PM
MINI2 Newbie
Offline
 
Join Date: Mar 2014
Location: staffordshire
Posts: 14
Local Time: 07:52 AM
United Kingdom
Update-
started to pull things apart after noticing strange noise from turbo, nuts come off inlet spindle, shaft has snapped in half so exhaust rotor spins but does not drive inlet, this has been catching housing.
All round a real mess! I then find out oil supply is poor and this is a known issue and mods are available on recall to cover supply pipe and fitting to turbo!
what else???
Reply With Quote
  #12 (permalink)  
Old Mar 20th, 2014, 09:12 PM
MINI2 Premium Member
MINI2 Master
Offline
 
Join Date: Mar 2012
Posts: 3,271
Local Time: 06:52 AM
United Kingdom Male
Hopefully no bits have been sucked into the engine, or have fallen into the manifold there waiting to be sucked in, make sure you give it a good check.
Reply With Quote
  #13 (permalink)  
Old Mar 26th, 2014, 09:41 PM
MINI2 Newbie
Offline
 
Join Date: Mar 2014
Location: staffordshire
Posts: 14
Local Time: 07:52 AM
United Kingdom
update

Right we are getting there! new turbo fitted after the last one snapped its spindle. cleaned every thing and rebuilt. Starts ok and sounds sweet but I am unsure how to set waste rod, can anyone help?? I have put it on but don't know if nuts are in right place as it seem to lack boost, is there a way of setting it up properly
Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 MINI Cooper Hardtop Revealed AutoGuide.com MINI News 13 Dec 12th, 2014 10:39 AM
PANORAMIC SUN ROOF ISSUES -I'm in talks with Mini Head Office UK PLEASE READ/CONTACT LadyUK General Discussion 53 Aug 9th, 2014 01:47 PM
high pressure fuel pump leak and head office lies! Shanos General Discussion 0 Nov 29th, 2013 05:24 PM
Newbie with a 2007 Mini Cooper and a 2010 Mini Cooper S JCW Converible dcphotos Welcome New Members 0 Sep 18th, 2012 01:05 AM

» Recent Threads
How best to sell Mini
Dec 13th, 2014 01:00 PM
Last post by UtilityGuy
Today 01:04 AM
4 Replies, 603 Views
Anyone know what this knob does?
Yesterday 12:19 PM
Last post by TomEdwards
Yesterday 08:54 PM
3 Replies, 196 Views
Light loose steering then EML light. Possible hump back bridge issue
Yesterday 04:44 PM
Last post by Davenegus
Yesterday 04:44 PM
0 Replies, 100 Views
Help please: Humpback bridge whoops steering odd and EML light
Yesterday 04:39 PM
Last post by Davenegus
Yesterday 04:39 PM
0 Replies, 97 Views
R56 MCS JCW cooling system problem?
Nov 15th, 2014 05:11 AM
Last post by Richard of the Hills
Yesterday 12:00 PM
1 Replies, 509 Views
How much do you pay in insurance?
Jul 24th, 2010 04:01 PM
Last post by whaap
Yesterday 11:56 AM
89 Replies, 34,955 Views
Airbag resistor value: 3.9 Ohms ? For sure ?
Nov 21st, 2003 09:18 PM
Last post by mab01uk
Yesterday 10:07 AM
4 Replies, 1,952 Views
Missing Functions
Dec 19th, 2014 12:57 AM
Last post by SteveB00
Yesterday 09:43 AM
9 Replies, 350 Views
Key button Door Unlock
Dec 19th, 2014 06:48 PM
Last post by heathwebbo
Yesterday 08:13 AM
1 Replies, 163 Views
engine will not start properly
Aug 12th, 2014 03:37 PM
by genik
Last post by genik
Yesterday 06:13 AM
5 Replies, 966 Views
mini cooper 2007 won't start
Yesterday 02:19 AM
by mc4400
Last post by mc4400
Yesterday 02:19 AM
0 Replies, 175 Views
No power under 4000 rpm and hard start
Oct 29th, 2014 11:39 PM
Last post by scrappyloz
Yesterday 01:41 AM
4 Replies, 778 Views
Cooper D DSC light and engine light
Dec 19th, 2014 11:56 PM
by hyvrid
Last post by hyvrid
Dec 19th, 2014 11:56 PM
0 Replies, 136 Views
Aux function not showing up
Dec 19th, 2014 10:57 PM
Last post by nahumbruhh
Dec 19th, 2014 10:57 PM
0 Replies, 134 Views
Chrome trim for 51 plate Mini Cooper
Dec 13th, 2014 12:28 PM
Last post by jessybaby96
Dec 19th, 2014 10:44 PM
4 Replies, 383 Views
Xenon lights problem
Dec 16th, 2014 07:49 PM
Last post by IloveMyMini1997
Dec 19th, 2014 09:16 PM
4 Replies, 461 Views
2008 mini cooper heating and fan problem
Dec 19th, 2014 07:07 PM
Last post by gtsmyth23
Dec 19th, 2014 07:07 PM
0 Replies, 139 Views
New MINI Cooper S Owners Roll Call.....
Nov 18th, 2006 10:20 PM
by Paul
Last post by RckStrGrl21
Dec 18th, 2014 09:59 PM
696 Replies, 171,908 Views
» Premium
» Auto Insurance
Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.1

All times are GMT. The time now is 06:52 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.3.2