2007 Mini Cooper S fuel issues - MINI Cooper Forum
Go Back   MINI Cooper Forum > MINI Technical Forums > MINI Faults & Fixes > Second Generation Faults & Fixes


Second Generation Faults & Fixes MINI faults and fixes Late 2006 - Present

Mini2.com is the premier Mini Cooper Forum on the internet. Registered Users do not see the above ads.
Reply
Similar Threads
Thread Thread Starter Forum Replies Last Post
PANORAMIC SUN ROOF ISSUES -I'm in talks with Mini Head Office UK PLEASE READ/CONTACT LadyUK General Discussion 53 Aug 9th, 2014 12:47 PM
2014 MINI Cooper Hardtop Revealed AutoGuide.com MINI News 12 Feb 12th, 2014 02:12 PM
high pressure fuel pump leak and head office lies! Shanos General Discussion 0 Nov 29th, 2013 04:24 PM
Newbie with a 2007 Mini Cooper and a 2010 Mini Cooper S JCW Converible dcphotos Welcome New Members 0 Sep 18th, 2012 12:05 AM

 
LinkBack Thread Tools Rate Thread
  #1 (permalink)  
Old Mar 15th, 2014, 08:12 PM
MINI2 Newbie
Offline
 
Join Date: Mar 2014
Location: staffordshire
Posts: 11
Local Time: 07:46 PM
United Kingdom
2007 Mini Cooper S fuel issues

My daughters mini stopped whilst driving and refused to restart for 10 mins, when it did it would not rev and seemed to be lacking fuel.
I got it home and noticed the fuel pump prime did not occur when inserting the fob to start. Having now removed the rear seat the fuel pump is not running for some reason?? if I get it to start it just cuts out after a few seconds.
I have discounted a High pressure pump fault as the tank pump is not running (no noise) any ideas -a wiring diagram would help.
thanks
Reply With Quote
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old Mar 15th, 2014, 09:04 PM
MINI2 Master
Offline
 
Join Date: Feb 2011
Location: South london
Posts: 1,190
Local Time: 07:46 PM
United Kingdom Male
Hi ya

I think I would check the Fuses or a relay first
Fuse box inside your car fuses f43 20 amp fuel pump relay
The relay it's self is the bottom relay in that fuse box by all the connectors at the bottom.
You can test the fuel pump by removing the relay and putting in a jumping lead between two terminals but I can not remember which ones I think as you look at it 9 and 3 o'clock but don't quote me on that. And it must be fused type of jumper lead

But if you put your hand on it, insert the key fob you should feel it click. Doing it this is not always 100% positive I have had relays click but still are faulty rare but it does happen.
If they are ok you need to check the fuel pump under the back seats and see if you have voltage there I think it the two Centre pins on the plug.
I have seen water and corrosion in the plug so might be with looking at that to


Hope this helps
Reply With Quote
Thanks for this post from:
  #3 (permalink)  
Old Mar 15th, 2014, 11:36 PM
MINI2 Newbie
Offline
 
Join Date: Mar 2014
Location: staffordshire
Posts: 11
Local Time: 07:46 PM
United Kingdom
Hi, thanks for that marque, I will try this tomorrow-I was unsure where the relay was but if looping it out proves the pump thats a good staring point.
I will let you know how things go
thanks
Reply With Quote
  #4 (permalink)  
Old Mar 16th, 2014, 09:51 AM
MINI2 Newbie
Offline
 
Join Date: Mar 2014
Location: staffordshire
Posts: 11
Local Time: 07:46 PM
United Kingdom
update

I have now checked for supply on the 20 amp fuse and its fine, if I remove the bottom relay (fuel pump?)all sorts of funny warning lights come on when I refit it. still no pump prime when I insert the fob,
I was wondering if this is the pump relay as it seems to work other things as well.
Marque-could I try a supply direct to the pump? if so which wires go on what pins and which way round + -?
thanks
john
Reply With Quote
  #5 (permalink)  
Old Mar 16th, 2014, 10:36 AM
MINI2 Newbie
Offline
 
Join Date: Mar 2014
Location: staffordshire
Posts: 11
Local Time: 07:46 PM
United Kingdom
update,
Put a direct supply on to pump + on pin 2(blue/white), - on pin 5(brown), pump runs fine. checked supply on connector to pump and nothing 0v. so its a 12v supply issue.
could someone confirm relay location for fuel pump????I now need to find this,and work out whats going on
thanks john
Reply With Quote
  #6 (permalink)  
Old Mar 16th, 2014, 12:30 PM
MINI2 Premium Member
MINI2 Master
Offline
 
Join Date: Mar 2012
Posts: 3,054
Local Time: 07:46 PM
United Kingdom Male
In the Bentley repair manual for the Gen 2 cars
Fuse for the fuel pump relay is F43 and its a 20amp
And it says the fuel pump relay is,
Quote:
"Junction box fuse and relay panel, right front behind kick panel trim cover. (assume that means in the footwell)
Relay K96 and looks like the relay is on the back of the board at the bottom right
Reply With Quote
  #7 (permalink)  
Old Mar 16th, 2014, 02:41 PM
MINI2 Newbie
Offline
 
Join Date: Mar 2014
Location: staffordshire
Posts: 11
Local Time: 07:46 PM
United Kingdom
fuel pump relay-2007 mini cooper s

Hi gents,
I am unsure were to go from here.
The relay on the front of the board seems to effect airbags etc, so is the fuel pump relay on the board at the back like the earlier R53? I am struggling to get a R56 wiring diagram which is making it worse.
thanks
Reply With Quote
  #8 (permalink)  
Old Mar 16th, 2014, 05:50 PM
MINI2 Premium Member
MINI2 Master
Offline
 
Join Date: Mar 2012
Posts: 3,054
Local Time: 07:46 PM
United Kingdom Male
It would appear its at the back yes, at least thats how it seems to read to me in the manual?
Reply With Quote
  #9 (permalink)  
Old Mar 17th, 2014, 11:27 AM
MINI2 Master
Offline
 
Join Date: Feb 2011
Location: South london
Posts: 1,190
Local Time: 07:46 PM
United Kingdom Male
hi ya

check all your fuses in the engine bay fuse box to

hope these pics help :-)
Attached Files
File Type: pdf 2014-03-17 11-12.pdf (279.1 KB, 28 views)
File Type: pdf 2014-03-17 11-13-04.pdf (357.5 KB, 23 views)
File Type: pdf 2014-03-17 11-14-27.pdf (347.9 KB, 20 views)
File Type: pdf 2014-03-17 11-19-12.pdf (339.8 KB, 20 views)
File Type: pdf 2014-03-17 11-20-45.pdf (309.4 KB, 21 views)
Reply With Quote
  #10 (permalink)  
Old Mar 19th, 2014, 08:37 PM
MINI2 Newbie
Offline
 
Join Date: Mar 2014
Location: staffordshire
Posts: 11
Local Time: 07:46 PM
United Kingdom
Update-I now know that pump does not run until you press the start button!
I was told it runs when you insert fob. Pump runs fine and I now have checked pressure at tank at 5 Bar so that's OK. Starts up and still stalls. very irratic to start.
Reply With Quote
  #11 (permalink)  
Old Mar 20th, 2014, 07:53 PM
MINI2 Newbie
Offline
 
Join Date: Mar 2014
Location: staffordshire
Posts: 11
Local Time: 07:46 PM
United Kingdom
Update-
started to pull things apart after noticing strange noise from turbo, nuts come off inlet spindle, shaft has snapped in half so exhaust rotor spins but does not drive inlet, this has been catching housing.
All round a real mess! I then find out oil supply is poor and this is a known issue and mods are available on recall to cover supply pipe and fitting to turbo!
what else???
Reply With Quote
  #12 (permalink)  
Old Mar 20th, 2014, 08:12 PM
MINI2 Premium Member
MINI2 Master
Offline
 
Join Date: Mar 2012
Posts: 3,054
Local Time: 07:46 PM
United Kingdom Male
Hopefully no bits have been sucked into the engine, or have fallen into the manifold there waiting to be sucked in, make sure you give it a good check.
Reply With Quote
  #13 (permalink)  
Old Mar 26th, 2014, 08:41 PM
MINI2 Newbie
Offline
 
Join Date: Mar 2014
Location: staffordshire
Posts: 11
Local Time: 07:46 PM
United Kingdom
update

Right we are getting there! new turbo fitted after the last one snapped its spindle. cleaned every thing and rebuilt. Starts ok and sounds sweet but I am unsure how to set waste rod, can anyone help?? I have put it on but don't know if nuts are in right place as it seem to lack boost, is there a way of setting it up properly
Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
PANORAMIC SUN ROOF ISSUES -I'm in talks with Mini Head Office UK PLEASE READ/CONTACT LadyUK General Discussion 53 Aug 9th, 2014 12:47 PM
2014 MINI Cooper Hardtop Revealed AutoGuide.com MINI News 12 Feb 12th, 2014 02:12 PM
high pressure fuel pump leak and head office lies! Shanos General Discussion 0 Nov 29th, 2013 04:24 PM
Newbie with a 2007 Mini Cooper and a 2010 Mini Cooper S JCW Converible dcphotos Welcome New Members 0 Sep 18th, 2012 12:05 AM

» Recent Threads
Electric window stopped working
Jul 6th, 2006 03:48 PM
Last post by regarp
Today 06:22 PM
34 Replies, 65,850 Views
Bonnet touching body
Aug 15th, 2014 03:47 PM
Last post by The Nun
Today 03:58 PM
3 Replies, 406 Views
Facebook page selling mini parts around the uk
Today 11:50 AM
by Alex93x
Last post by Restyle
Today 03:25 PM
2 Replies, 85 Views
New Mini Cooper D - Worth the money?
Today 01:33 PM
Last post by dangoodwin
Today 01:33 PM
0 Replies, 69 Views
Mini Clubman Barn Doors Won't Lock
Oct 22nd, 2014 03:51 AM
Last post by WeeBad
Today 01:03 PM
3 Replies, 394 Views
R56 Footwell module dead
Jul 15th, 2014 04:19 AM
by miniuy
Last post by k3fus
Today 07:16 AM
6 Replies, 1,244 Views
inside lights
Yesterday 11:19 PM
Last post by bigmamabear
Yesterday 11:19 PM
0 Replies, 138 Views
Lights on warning not working
Oct 21st, 2014 11:42 AM
by S2dicky
Last post by S2dicky
Yesterday 09:16 PM
4 Replies, 462 Views
Smoked Headlight Covers GTO276S
Yesterday 08:49 PM
by tmath23
Last post by tmath23
Yesterday 08:49 PM
0 Replies, 148 Views
engine fan on more frequently
Oct 16th, 2014 01:46 PM
Last post by stewarth
Yesterday 07:27 PM
3 Replies, 641 Views
Cooper S judders when idle...
Jul 17th, 2010 04:53 PM
by ben_uk
Last post by Restyle
Yesterday 06:18 PM
6 Replies, 1,100 Views
R56 Aux input volume???????
Oct 20th, 2014 04:00 PM
Last post by Dermottdog
Yesterday 06:00 PM
4 Replies, 549 Views
Start/Stop engine button illuminated when car is locked
Oct 21st, 2014 08:07 PM
Last post by The Nun
Yesterday 05:03 PM
6 Replies, 534 Views
Wheel arch - advice please :)
Oct 22nd, 2014 10:08 PM
Last post by The Nun
Yesterday 05:00 PM
2 Replies, 248 Views
No spray on windshield wiper
Oct 19th, 2014 08:54 PM
by mom7x
Last post by CCroker
Yesterday 01:57 PM
2 Replies, 442 Views
Will I get jipped?
Oct 21st, 2014 11:14 PM
Last post by CCroker
Yesterday 01:52 PM
3 Replies, 376 Views
Rear wiper motor stem problem
Oct 18th, 2014 09:57 AM
Last post by ihughes
Yesterday 01:34 PM
4 Replies, 568 Views
2010 Cooper S
Yesterday 01:13 PM
Last post by mike_1979
Yesterday 01:13 PM
0 Replies, 199 Views
2001 Mini Cooper - heater not working
Oct 22nd, 2014 08:41 AM
by TreezaB
Last post by TreezaB
Yesterday 07:48 AM
2 Replies, 329 Views
$95 @ Willow Springs Streets of Willow November 15-16 2014
Yesterday 01:37 AM
by harvie
Last post by harvie
Yesterday 01:37 AM
0 Replies, 175 Views
» Premium
» Auto Insurance
Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.1

All times are GMT. The time now is 06:46 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.3.2