2007 r56 D cooper issues...fuel additive, gear stick and passenger window - MINI Cooper Forum

Second Generation Faults & Fixes MINI faults and fixes Late 2006 - Present

User Tag List

 
LinkBack Thread Tools Rate Thread
post #1 of 2 (permalink) Old Apr 26th, 2014, 06:18 AM Thread Starter
MINI2 Newbie
 
Join Date: Apr 2014
Local Time: 09:26 AM
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

 
2007 r56 D cooper issues...fuel additive, gear stick and passenger window

I'm just on my 2nd cooper D. I've driven the new (to me)car for about 2000 miles and have noticed a few differences between it and my previous incarnation. The new car is on 50k miles and the old was on 98k.
Firstly although there is no loss in power or performance, the new car seems to sound a little rougher on running...the Eos additive seems not to be working as the service indicator shows no change (ie it remains on 100000 miles til next service)...is there anyway to check the pump is working and the additive is being added without a trip to the $tealers? And would this make the car appear to run rough?
2ndly, the gear stick rattles when in neutral. Light pressure stops this but it is annoying...I've read on here that this can be the? Sender? Or a loose engine mount on the 1st generation mini, is this the same for the 2nd generation and given it is a known fault is it something Bmw will fix gratis (hahahahaha)??Given that is mildly unlikely what and where should I be looking?
Finally the passenger side window doesn't drop when opening and closing the door...I'm thinking a dodgy sensor but again am not sure where to look?
Many thanks in anticipation of any help
domross is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Apr 26th, 2014, 11:20 AM Thread Starter
MINI2 Newbie
 
Join Date: Apr 2014
Local Time: 09:26 AM
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

 
Ok...with regards to the gearstick...further research would appear to show it's the gearbox selector ,not sender that is the problem....anyone any idea how to change this??
domross is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MINI Cooper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome