Engine not keen to rev past 4000rpm - MINI Cooper Forum

Second Generation MINI Cooper S MINI Cooper S Late 2006 - Present

User Tag List

 
LinkBack Thread Tools Rate Thread
post #1 of 4 (permalink) Old Feb 23rd, 2013, 05:58 PM Thread Starter
MINI2 Newbie
 
Join Date: Jul 2007
Location: Solihull UK
Local Time: 04:23 AM
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

United Kingdom View AMCQ46's Classified Ads
 
Engine not keen to rev past 4000rpm

Hello all, not posted here much but been a 2 time mini owner and have used this site to understand and fix most of the problems i had on my old gen1 cooper.

I have had a search and don't see anything similar to this one on my newer MCS, so here is the problem:

The car is a 2006 MCS convertible, so the first yr that that the new engine went into the rag top. It has 30000 miles on it and although used mostly for commuting, it gets thrashed when the conditions suit

So today I was out in the Cotswolds and went for a quick overtake and I thought the engine was a bit flat and I wasnt accelerating like I expected so I aborted the overtake and did a quick experiment. I was in 3rd at about 3000revs and the sport button on, and I floored it and guess what, it wasn't that keen to get past 4000 and there was no way it was going to get to the redline!! Doing this I would normally expect it shoot through the revs like a scalded cat, but repeated tests didn't give me any different!
The bottom end and mid range feel the same, just the top end revs are not there!

Is it the electronics or do I have another problem? All help gratefully received as I am not keen to go pay mini prices for them to try and diagnose this.


Edit, I did try ignition off and back on, and on the return trip it felt a bit better, but still not full fat.
AMCQ46 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Feb 26th, 2013, 06:47 PM
MINI2 Newbie
 
Join Date: Oct 2012
Location: Lancashire
Local Time: 05:23 AM
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

United Kingdom Male
 
I had the same problem, made a post about something related. The turbo wasn't kicking in properly. Check the turbo air intake is secure and pushed all the way on. Oil works it's way in and allows the pipe to work it's way off.
JGrimshaw is offline  
post #3 of 4 (permalink) Old Feb 26th, 2013, 08:06 PM
MINI2 Newbie
 
Join Date: Apr 2012
Local Time: 05:23 AM
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

United Kingdom
 
WHS ^^ Sounds more like a turbo problem, as it should kick in at those revs, can you hear the turbo whine at all when you boot it?
lard is offline  
post #4 of 4 (permalink) Old Feb 27th, 2013, 04:56 PM
MINI2 Master
 
Paul@1320's Avatar
 
Join Date: Jul 2005
Location: Beds Cambs Northants
Local Time: 04:23 AM
Posts: 2,170
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

United Kingdom
 
On the R56 we notice a lot of issues where the ecu will limit the boost, proberly best to book it to your local MINI specialist who has teh right diagnostic equipment and a rolling road.
Paul@1320 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MINI Cooper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome