Engine not keen to rev past 4000rpm - MINI Cooper Forum
Go Back   MINI Cooper Forum > Model Specific MINI Forums > MINI Cooper S > Second Generation MINI Cooper S


Second Generation MINI Cooper S MINI Cooper S Late 2006 - Present

Mini2.com is the premier Mini Cooper Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread
  #1 (permalink)  
Old Feb 23rd, 2013, 05:58 PM
MINI2 Newbie
Offline
 
Join Date: Jul 2007
Location: Solihull UK
Posts: 11
Local Time: 01:44 PM
United Kingdom View AMCQ46's Classified Ads
Engine not keen to rev past 4000rpm

Hello all, not posted here much but been a 2 time mini owner and have used this site to understand and fix most of the problems i had on my old gen1 cooper.

I have had a search and don't see anything similar to this one on my newer MCS, so here is the problem:

The car is a 2006 MCS convertible, so the first yr that that the new engine went into the rag top. It has 30000 miles on it and although used mostly for commuting, it gets thrashed when the conditions suit

So today I was out in the Cotswolds and went for a quick overtake and I thought the engine was a bit flat and I wasnt accelerating like I expected so I aborted the overtake and did a quick experiment. I was in 3rd at about 3000revs and the sport button on, and I floored it and guess what, it wasn't that keen to get past 4000 and there was no way it was going to get to the redline!! Doing this I would normally expect it shoot through the revs like a scalded cat, but repeated tests didn't give me any different!
The bottom end and mid range feel the same, just the top end revs are not there!

Is it the electronics or do I have another problem? All help gratefully received as I am not keen to go pay mini prices for them to try and diagnose this.


Edit, I did try ignition off and back on, and on the return trip it felt a bit better, but still not full fat.
Reply With Quote
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old Feb 26th, 2013, 06:47 PM
MINI2 Newbie
Offline
 
Join Date: Oct 2012
Location: Lancashire
Posts: 5
Local Time: 02:44 PM
United Kingdom Male
I had the same problem, made a post about something related. The turbo wasn't kicking in properly. Check the turbo air intake is secure and pushed all the way on. Oil works it's way in and allows the pipe to work it's way off.
Reply With Quote
  #3 (permalink)  
Old Feb 26th, 2013, 08:06 PM
MINI2 Newbie
Offline
 
Join Date: Apr 2012
Posts: 22
Local Time: 02:44 PM
United Kingdom
WHS ^^ Sounds more like a turbo problem, as it should kick in at those revs, can you hear the turbo whine at all when you boot it?
Reply With Quote
  #4 (permalink)  
Old Feb 27th, 2013, 04:56 PM
Paul@1320's Avatar
MINI2 Master
Offline
 
Join Date: Jul 2005
Location: Beds Cambs Northants
Posts: 2,170
Local Time: 01:44 PM
United Kingdom
On the R56 we notice a lot of issues where the ecu will limit the boost, proberly best to book it to your local MINI specialist who has teh right diagnostic equipment and a rolling road.
Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

» Hot Topics This Week
New Online Magazine for Track Day Enthusiasts - (21 replies)
Warning lights - (18 replies)
Carbon build up on inlet valves - (15 replies)
heat problem - (14 replies)
ABS Sensor - (13 replies)
» Recent Threads
R56 Engine backward compatibility?
Today 12:37 PM
Last post by Carlos Fandango
Today 12:37 PM
0 Replies, 20 Views
Urgent Help Please - Failed MOT on CO emissions
Today 12:30 PM
Last post by Mark1961
Today 12:30 PM
0 Replies, 24 Views
heat problem
Aug 24th, 2014 10:04 AM
Last post by rob955triumph
Today 11:37 AM
14 Replies, 976 Views
What is this sound? R53
Yesterday 10:01 AM
by gmb
Last post by The Nun
Today 11:07 AM
3 Replies, 216 Views
Thought id play with lights coz I was bored
Today 01:54 AM
Last post by The Nun
Today 11:05 AM
1 Replies, 132 Views
Parking Sensor ECU
Aug 29th, 2014 09:59 AM
Last post by The Nun
Today 10:36 AM
4 Replies, 300 Views
57 Cooper S boot and passenger door
Aug 23rd, 2014 01:07 PM
Last post by ihughes
Today 09:28 AM
5 Replies, 541 Views
R50 Problems, how common?
Aug 10th, 2014 11:08 AM
by aypea
Last post by dsakko
Today 06:16 AM
7 Replies, 810 Views
What is this sound? R53
Today 12:04 AM
by gmb
Last post by SteveAus
Today 01:42 AM
1 Replies, 131 Views
Warning lights
Feb 25th, 2010 04:52 PM
Last post by Dave Elliott
Yesterday 11:28 PM
18 Replies, 6,755 Views
Runflat Light On?
Mar 31st, 2010 08:05 AM
by AlanJCW
Last post by Dave Elliott
Yesterday 11:26 PM
7 Replies, 1,636 Views
ABS Sensor
Apr 8th, 2010 09:58 AM
by Sealsey
Last post by Dave Elliott
Yesterday 11:25 PM
13 Replies, 6,494 Views
All wheel spin related warning lights are on after wheel bearing replacement
May 12th, 2012 11:29 PM
by suvnot
Last post by Dave Elliott
Yesterday 11:17 PM
9 Replies, 2,743 Views
Hey admins!
Yesterday 11:32 AM
by doxbike
Last post by timp
Yesterday 08:28 PM
4 Replies, 240 Views
2006 R53 vs 2009 R56
Yesterday 06:23 PM
Last post by Caveman
Yesterday 07:05 PM
3 Replies, 197 Views
Spare key question
Yesterday 05:31 PM
by moblies
Last post by moblies
Yesterday 05:31 PM
0 Replies, 162 Views
Cannot see video or album artwork on visual boost
Yesterday 03:33 PM
by rich345
Last post by rich345
Yesterday 03:33 PM
0 Replies, 141 Views
R53 Cooper S starting issues.
Yesterday 03:14 PM
by D8DEL
Last post by D8DEL
Yesterday 03:14 PM
0 Replies, 159 Views
2015 Countryman
Yesterday 12:59 PM
by Sophia7
Last post by Sophia7
Yesterday 12:59 PM
0 Replies, 151 Views
2013 Hardtop 110v outlet
Aug 30th, 2014 06:33 AM
Last post by timp
Yesterday 09:16 AM
6 Replies, 378 Views
» Premium
» Auto Insurance
Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.1

All times are GMT. The time now is 01:44 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.3.2