Mini Cooper S 2008 R56 - MINI Cooper Forum

Second Generation MINI Cooper S MINI Cooper S Late 2006 - Present

User Tag List

 
LinkBack Thread Tools Rate Thread
post #1 of 2 (permalink) Old Aug 7th, 2014, 04:51 AM Thread Starter
MINI2 Newbie
 
Join Date: Aug 2014
Local Time: 03:15 PM
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

United States
 
DIY Mini Cooper S 2008 R56

Hey There!
I'm new to this forum and I hope it can help me find out what's troubling my car.
I have a Mini Cooper S R56 2008
it has over 100,000 miles I bought it used and recently it just started giving me problems (i've had it for 2 to 3 years)
My problem now is I checked the car with my obdII reader and it has the codes P0300,P0301,P0302,P0304, and it also had a code previous to these which was P1497, P2178 and P2187.
I recently changed all four of the spark plugs (with a non-brand spark plugs) and the ignition coils with Bremi ignition coils before it had Delphi ignition coils.
Now let me explain the problem:
When I turn on the car I leave it on for a while to get warm and adjusted then as I head off to drive when I try to accelerate it doesn't accelerate as it should, sometimes the RPM goes from 3 to 4 when I'm only going at 10 to 20 mph, it has also turned off on me while I am at the stop light, or the car feels like it's revving up, while I am at a stoplight.
I don't know what causes the problem or what happened but can someone please help me and tell me what could be the problem I've read the codes and they deal with the hose or the fuel tank but I'm not quite sure what to do or what I should fix so if you have any suggestions or anything in mind please let me know and I will try to figure it out and post back an update of what I've done and when the problem fixes.
Thanks again!
[My_Mini] is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Aug 17th, 2014, 07:01 AM
MINI2 Regular
 
Join Date: May 2013
Location: Adelaide, Australia
Local Time: 10:15 PM
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Australia
 
Your problem could be the High Pressure Fuel Pump.

My wife's 2009 Cooper S had an issue a couple of years ago when the car was difficult to start and run, and the fault was diagnosed as a Thermostat problem. The thermostat was replaced but the problem not fully resolved.

A week or two later the car started dying and then revving hard - resulting in the car lurching dangerously. At this point she refused to drive the car anymore and insisted that Mini come and pick up the car and fix it properly.

Mini replaced the HPFP and we have not had any problems since.

2009 R56 Mini Cooper S: Chili Red, Black Roof, Black Wheels, ASC+T, SatNav, Very Cute!
SteveAus is offline  
Sponsored Links
Advertisement
 
Reply
Tags: , , , , , , , , , , ,


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MINI Cooper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 MINI Cooper Hardtop Revealed AutoGuide.com MINI News 15 Apr 23rd, 2015 03:15 PM
New 14 plate Mini Cooper SD Coupe Nightmare Kickboxkel Welcome New Members 7 Apr 4th, 2015 12:33 PM
CVT Transmission Failure slaybalj First Generation CVT & Automatic 142 Oct 15th, 2014 10:48 AM
Steve McQueen's Mini Cooper S mab01uk MINI in the Media 0 Jul 25th, 2014 10:45 PM
2008 R56 Mini Cooper S Turbo! RGJACOBSON Welcome New Members 0 Dec 26th, 2012 12:48 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome