2003 mini cooper s engine ticking noise when idling. - MINI Cooper Forum

Welcome New Members New members, please introduce yourself here. Tell us a bit about you and your Mini.

User Tag List

 
LinkBack Thread Tools Rate Thread
post #1 of 3 (permalink) Old Feb 14th, 2014, 01:29 PM Thread Starter
MINI2 Newbie
 
Join Date: Feb 2014
Local Time: 12:59 PM
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

United States
 
United-States 2003 mini cooper s engine ticking noise when idling.

Hi all! I've been the proud owner of a 2003 Mini Cooper S for a year now. It's been a great vehicle until recently. I start my baby car, as I call it, and when the car gets up to temp, it make a loud ticking noise. It doesn't go away when you step on the clutch. It goes away when it reaches about 1800 to 2000 rpms. Just had it in to replace the spark plugs and the oil filter housing, also something to do with a pcv bolt. What could be the problem? I would like to have my baby car for a long time and I need to figure out what my options might be. Any help would be greatly appreciated! Thanks!
tlw3333 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Feb 14th, 2014, 02:03 PM
MINI2 Master
 
Join Date: Feb 2011
Location: South london
Local Time: 06:59 PM
Posts: 1,224
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

United Kingdom Male
 
Hi ya

How many miles you have on your car and has it any mods

It could be a few things

Check you harmonic crank pulley they fail and make the same sound as your describing and my one sounded like the clutch was gone.
But I would say it sounds like you clutch is failing it could be the dual mass flywheel rattling or may be a clutch plate, pressure plate or thrust bearing failing

Hope this help
marque is offline  
post #3 of 3 (permalink) Old Feb 14th, 2014, 02:09 PM Thread Starter
MINI2 Newbie
 
Join Date: Feb 2014
Local Time: 12:59 PM
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

United States
 
United-States Thanks

My car has 119,000 miles on it. So it could be the clutch? It doesn't affect the noise that the car is making. I push in the clutch and the noise does not go away. The car starts fine and there is no noise right away, but when the car warms up a bit, then it starts sounding chunky like a diesel engine. You really think it would be related to the clutch? I will check it out and see. I didn't mention earlier, but there is the distinct smell of gas when it is idling and even when driving. Could this have anything to do with my problem? No mods that I know of.

Last edited by tlw3333; Feb 14th, 2014 at 07:49 PM.
tlw3333 is offline  
Sponsored Links
Advertisement
 
Reply
Tags: , ,


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MINI Cooper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 MINI Cooper Hardtop Revealed AutoGuide.com MINI News 15 Apr 23rd, 2015 03:15 PM
Please help! My car won't start & makes clicking noise... 2003 Mini Cooper Tyna General Discussion 3 Feb 1st, 2014 09:38 PM
Oil consumption Mini Cooper s N18 engine peterhellawell Maintenance & MINI Care 1 Jan 24th, 2013 09:11 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome