Speedo stop working - MINI Cooper Forum

Welcome New Members New members, please introduce yourself here. Tell us a bit about you and your Mini.

User Tag List

 
LinkBack Thread Tools Rate Thread
post #1 of 1 (permalink) Old Apr 30th, 2014, 12:44 AM Thread Starter
MINI2 Newbie
 
Join Date: Apr 2014
Local Time: 07:35 AM
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Canada
 
Speedo stop working

I have a 2005 mini cooper that i have taken to a mechanic because 3 lights went on after I put air on my tires.
He said he fixed the problem witch it was a sensor on the left from wheel but after he did that, all the ligths are still on plus the brake light went o as well. Also, I now cannot open my top (it is convetible) and I have no speedo
ninethe is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MINI Cooper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Manual speedo in automatic car!! Zippy34 First Generation Faults & Fixes 3 Mar 28th, 2014 10:26 PM
Mini One 2002 Speedo needle not working emmsyg First Generation Faults & Fixes 7 Mar 27th, 2014 09:43 PM
Dashboard lights not working? AlanB11 General Discussion 12 Dec 1st, 2013 11:06 PM
Turbo replacement, start stop no longer working Porn_Star19 Second Generation Faults & Fixes 12 Feb 26th, 2013 04:01 PM
Rattle in speedo Ken White Second Generation Works 8 Jan 11th, 2013 07:27 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome