new to us - MINI Cooper Forum

Welcome New Members New members, please introduce yourself here. Tell us a bit about you and your Mini.

User Tag List

LinkBack Thread Tools Rate Thread
post #1 of 3 (permalink) Old Jul 23rd, 2014, 01:08 AM Thread Starter
MINI2 Newbie
Join Date: Jul 2014
Location: kansas
Local Time: 08:44 AM
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

United States Male
Question new to us

We bought a 2004 Mini Cooper last week. We have problems already. The service engine light is on, despite filling up with premium gasoline (petrol), although we know that the previous owner used regular gasoline. We are hoping that after a few more fueling trips this will correct itself.

Additionally, our rear brake lights and none of our turn signals (front, side, rear) are not working. Only the four-way flashing works on the right side rear, but no other locations. When I checked the various lights with a volt meter and test light, they indicated that only the tail lights or running lights were functional in the rear multi-light unit,. The middle brake light in the hatchback door is operating. I checked the fuses in the passenger compartment near the driver footwell, but was unable to locate a blown fuse.

We cleared the EML of 10 trouble codes, but we haven't a source for looking up the codes. Does anyone have a reliable source for a 2004 Mini Cooper trouble codes?

I went through all of the fuses to test that power was at each fuse location. Fuse #5 in the passenger compartment driver footwell fusebox panel doesn't get any power to it. I'm not sure what that fuse powers.

Any thoughts/ suggestions?

Thanks so much.

Last edited by Rene.163; Jul 23rd, 2014 at 02:23 AM. Reason: clarification
Rene.163 is offline  
Sponsored Links
post #2 of 3 (permalink) Old Jul 23rd, 2014, 05:36 PM
MINI2 Master
Caveman's Avatar
Join Date: Jul 2002
Location: Stone Age
Local Time: 10:44 AM
Posts: 2,684
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 60 Post(s)

Estonia Male View Caveman's Classified Ads
Check other forums ...

1st Gen Faults & Fixes - Fault Codes

Maintenance & Care - Fuses, Relays & Earth Points
Caveman is offline  
post #3 of 3 (permalink) Old Jul 23rd, 2014, 06:04 PM
MINI2 Regular
Join Date: Jun 2014
Local Time: 08:44 AM
Posts: 68
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Welcome aboard!
mini2mini2 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the MINI Cooper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome