Clutch Issue - MINI Cooper Forum

First Generation Faults & Fixes MINI faults and fixes 2001 - 2006

 
LinkBack Thread Tools Rate Thread
post #1 of 2 (permalink) Old Jan 19th, 2017, 01:46 AM Thread Starter
MINI2 Newbie
 
Join Date: Oct 2016
Local Time: 02:17 PM
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)

 
Clutch Issue

Hi everyone!
(First post fyi)
So a few days ago I went to drive my 03 Mini Cooper S (R53) and noticed that my clutch pedal easily went to the floor and it was really hard to get it into gear/shift. The pedal would come back up on its own but when I went to press it, there was very little resistance.
After doing research I've come to the conclusion there is an issue either with my slave or master cylinder, or possibly the hose.
Today, I bled the slave a little to see if I could get any air bubbles out, but there were none. And there is no leak at the slave or master...
Tomorrow my plan is to bleed the entire thing and fill with new fluid (the old fluid was old and gross) and see if that changes anything?
Right now I am thinking there is an issue within my master cylinder but I'm not sure
Has anyone had a similar issue or possibly know what is wrong?
I really appreciate any input! Thank you!
Also, keep in mind I am financially independent college student (no ma or pa to help pay) so I can't afford to take it to the shop to spend thousands on labor... aha
Thanks once again
[/INDENT][/INDENT]

tgarcia is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Jan 19th, 2017, 03:19 AM
MINI2 Master
 
Join Date: Apr 2014
Location: Melbourne
Local Time: 12:17 AM
Posts: 1,893
Mentioned: 40 Post(s)
Quoted: 292 Post(s)

Australia Male
 
Garage
See if this helps. Would be advantageous if you have a 1 man pressure bleed kit.

this is the type of pressure bleed kit you would want.

SP Tools Brake And Clutch Pressure Bleeding Kit SP70809 | eBay

see if the attached pdf helps and look at Modmini's video on YouTube for bleeding a Gen 1 clutch slave

Attached Files
File Type: pdf Mini-Cooper-R53-Clutch-Slave-Installation.pdf (434.0 KB, 59 views)
Milpol is offline  
Sponsored Links
Advertisement
 
Reply
Tags: , , , , ,


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MINI Cooper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch Hydraulics - Slave Issue CrazyCrisUk First Generation Faults & Fixes 0 Sep 14th, 2016 02:06 PM
Mini JCW possible clutch issue? fastandred Second Generation Works 2 Nov 29th, 2014 07:53 AM
Gear box and clutch issue minimenz First Generation Faults & Fixes 4 Oct 12th, 2012 04:32 AM
Looking at Mini - Clutch Issue questions Captain45 General Discussion 1 Aug 22nd, 2012 09:50 PM
Clutch issue? SnoopMarky First Generation Faults & Fixes 4 Aug 14th, 2012 02:27 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome