2004 R53 Window Regulator w/motor - MINI Cooper Forum

First Generation Interior & Ice
Find Sponsor products associated with this forum
First generation MINI interior 2001 - 2006

 
LinkBack Thread Tools Rate Thread
post #1 of 3 (permalink) Old Jul 9th, 2018, 12:23 AM Thread Starter
MINI2 Newbie
 
Join Date: Jan 2015
Local Time: 07:02 AM
Posts: 7
Mentioned: 0 Post(s)
Quoted: 4 Post(s)

 
Question 2004 R53 Window Regulator w/motor

Having issues with Passenger window regulator... I have went through 3 dorman and I know someone is going to say that's the issue... and it might be. I've replaced the drivers side also with EvanFisher unit due to exist one was making horrible noise... knock on wood that's one has been fine. What I'm finding on the passenger side the regulator cables are bind. I'm thinking what ever tells the motor to stop isn't working right and it's the motor causing the cables to bind. Might be wrong and that's why I'm posting so someone could share what they know.

So in my local salvage yard, 2006 model shows up... figured I would grab it because I'm thinking most like OEM regulator and motor. Well, after taking it out I wasn't sure it was OEM. Started Google searching and it is but the gears are different. Seem like the motor is different on 2006 units. The connector on 2004 are blue while this 2006 is yellow. So visually the connector color and mounting orientation is different and the gear appearance.

Now I'm thinking I can't use it due to connector. Anyone else dealt with this situation before? Please share..

Thanks!


TurboRabbit is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Jul 9th, 2018, 07:30 AM
MINI2 Master
 
Join Date: Apr 2017
Location: down west somewhere
Local Time: 07:02 AM
Posts: 4,012
Mentioned: 14 Post(s)
Quoted: 631 Post(s)

United Kingdom Male
 
Quote:
Originally Posted by TurboRabbit View Post
Having issues with Passenger window regulator... I have went through 3 dorman and I know someone is going to say that's the issue... and it might be. I've replaced the drivers side also with EvanFisher unit due to exist one was making horrible noise... knock on wood that's one has been fine. What I'm finding on the passenger side the regulator cables are bind. I'm thinking what ever tells the motor to stop isn't working right and it's the motor causing the cables to bind. Might be wrong and that's why I'm posting so someone could share what they know.

So in my local salvage yard, 2006 model shows up... figured I would grab it because I'm thinking most like OEM regulator and motor. Well, after taking it out I wasn't sure it was OEM. Started Google searching and it is but the gears are different. Seem like the motor is different on 2006 units. The connector on 2004 are blue while this 2006 is yellow. So visually the connector color and mounting orientation is different and the gear appearance.

Now I'm thinking I can't use it due to connector. Anyone else dealt with this situation before? Please share..

Thanks!
if window regulators come from same model then its just a update with gears and electrical plug or after market one was fitted at some point, i've the 2006 car is a later r56 model then chances are it might not fit the earlier r50 r53 r52 cars.. as when mini went over to the r56 it was totally designed by bmw,, where the first gen's were designed by rover group/honda, so bmw used as much of their own parts and designs in the later cars, this said no harm seeing if will fit if holes line up and electrical plugs fit worth a punt,
added note below link is repair kit use them all the time its a pain the first time to fit top tip use a small cable tie to hold the cables on the cable drum after winding them on to it and loosely put in plastic case while installing motor, also fit cables to window sliders before winding the drums as such,
https://www.ebay.co.uk/itm/Mini-Coop...8AAOSwnw9aIWYT


Albert Einstein: The definition of insanity is doing the same thing over and over and expecting different results.
mike1967 is online now  
post #3 of 3 (permalink) Old Jan 7th, 2019, 10:45 PM
JayWye
 
Join Date: Jan 2019
Local Time: 07:02 AM
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)

 
in June 2005,the window motors changed. when you order a new motor online,they say if it's for pre-05 or newer. At least Rock Auto and Autozone did.
I have an 05 R53,and am getting ready to replace the regulator and motor. AGAIN.
Nobody ever mentioned the regulator cables and sliding surfaces have to be LUBRICATED,which is probably why the LAST TWO regulators only lasted a bit longer than a year. Now I just have to find out what lubricant is right for this.
JayWye is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MINI Cooper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 Convertible window regulator question Maria T General Discussion 1 Feb 25th, 2018 09:11 PM
2005 r52 drivers window motor and regulator simbad111 General Discussion 0 Jan 13th, 2014 04:32 PM
Can you get replacement window regulator cables? MGFmad First Generation Faults & Fixes 0 Oct 4th, 2011 08:36 PM
Advice on removing window regulator and motor craigrich First Generation Faults & Fixes 3 Jan 5th, 2011 07:57 PM
2003 mini cooper window regulator on drivers side is bad 2003minicooper First Generation Faults & Fixes 0 Nov 27th, 2010 11:53 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome