Mini Cooper R56 Radio Problem - MINI Cooper Forum

General Discussion Use this forum to discuss MINI topics which are not related to other forums. Posts may be moved from here to alternative forums by the moderators without notice

 
LinkBack Thread Tools Rate Thread
post #1 of 9 (permalink) Old Apr 1st, 2013, 05:38 PM Thread Starter
MINI2 Newbie
 
Join Date: Apr 2013
Local Time: 08:03 AM
Posts: 1
Mentioned: 0 Post(s)
Quoted: 1 Post(s)

 
Mini Cooper R56 Radio Problem

hello everyone i have a mini cooper 56 reg (2006 November model) and a few weeks ago i was listening to the radio and it just cut out and made a noise (like a thud) then some times it would come back on but not for long.

no i am unable to turn the radio on and the led display wont come on as well.

i have taken the radio out and was wondering if anyone had any suggestions ???

thanks
Curtis

Curtisblythe is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old Apr 23rd, 2014, 01:45 PM
MINI2 Newbie
 
Join Date: Apr 2014
Location: Houston
Local Time: 08:03 AM
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)

Male
 
Quote:
Originally Posted by Curtisblythe View Post
hello everyone i have a mini cooper 56 reg (2006 November model) and a few weeks ago i was listening to the radio and it just cut out and made a noise (like a thud) then some times it would come back on but not for long.

no i am unable to turn the radio on and the led display wont come on as well.

i have taken the radio out and was wondering if anyone had any suggestions ???

thanks
Curtis
Did you ever find out the problem? I have a 08 r56 n it started to do the same, I was wondering if you diagnosed the problem.

gm_MiniCoopsta is offline  
post #3 of 9 (permalink) Old Sep 17th, 2014, 05:01 PM
MINI2 Newbie
 
Join Date: Sep 2014
Local Time: 09:03 AM
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)

United Kingdom
 
Anyone ever solve this? Couple of threads on the same vein with no answers...

Our mini has just done exactly this. Driving along, stereo fine, turn the car off and go to work- come back to a dead stereo.

Checked all fuses, including engine bay fuse and the rear of the stereo. LED display dead, only thing it will do is eject/accept a cd.
Dooper09 is offline  
 
post #4 of 9 (permalink) Old Feb 25th, 2015, 12:51 PM
Registered User
 
Join Date: Feb 2015
Local Time: 08:03 AM
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)

 
anyone come up with a solution yet?

I've had a similar issue with my R56 Radio. Turned car off and locked it but the radio was stuck on. Eventually it went off, but now the radio is stuck on the same station and i can't change to CD or eject.
babybel is offline  
post #5 of 9 (permalink) Old Feb 26th, 2015, 10:22 AM
MINI2 Newbie
 
camonixo's Avatar
 
Join Date: Dec 2014
Local Time: 09:03 AM
Posts: 6
Mentioned: 0 Post(s)
Quoted: 1 Post(s)

United Kingdom
 
Hi, I have a r53 '04 and I had a similar problem,my radio stopped and displayed 'phone' the system hasn't got a blue tooth... yes my cd would open and load but nothing else, I took it to the garage and they say its a radio failure and either send to manufacture for repair or replace it....hope this helps..
camonixo is offline  
post #6 of 9 (permalink) Old Feb 26th, 2015, 10:52 AM
MINI2 Privilege Member
MINI2 Master
 
Join Date: Mar 2012
Local Time: 09:03 AM
Posts: 3,829
Mentioned: 0 Post(s)
Quoted: 53 Post(s)

United Kingdom Male
 
Quote:
Originally Posted by camonixo View Post
Hi, I have a r53 '04 and I had a similar problem,my radio stopped and displayed 'phone' the system hasn't got a blue tooth... yes my cd would open and load but nothing else, I took it to the garage and they say its a radio failure and either send to manufacture for repair or replace it....hope this helps..
If the garage has looked at it and confirmed it is a radio fault then so be it, but you can accidentally select mute or press the phone symbol on the steering wheel which switches the speakers off for when you have the phone facility and this still works even if theres no phone facility fitted.
The Nun is offline  
post #7 of 9 (permalink) Old Oct 25th, 2015, 06:02 PM
MINI2 Newbie
 
Join Date: Sep 2014
Local Time: 09:03 AM
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)

United Kingdom
 
Just to respond to this - our stereo was dead. I suspect the Amp died in the HU. I bought one from a mini breakers in Nuneaton (top guy) and he coded it for me to get the aux in to start working.
Dooper09 is offline  
post #8 of 9 (permalink) Old Jun 11th, 2019, 04:08 AM
MINI2 Newbie
 
Join Date: Jun 2019
Local Time: 08:03 AM
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)

 
Quote:
Originally Posted by Curtisblythe View Post
hello everyone i have a mini cooper 56 reg (2006 November model) and a few weeks ago i was listening to the radio and it just cut out and made a noise (like a thud) then some times it would come back on but not for long.

no i am unable to turn the radio on and the led display wont come on as well.

i have taken the radio out and was wondering if anyone had any suggestions ???

thanks
Curtis
Hi

I am having the same issue. All fuses are working, including the one behind the radio. Did you find a solution?

Thanks
Mati is offline  
post #9 of 9 (permalink) Old Jun 11th, 2019, 04:10 AM
MINI2 Newbie
 
Join Date: Jun 2019
Local Time: 08:03 AM
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)

 
Any luck about this issue? I have the same problem. Thanks
Mati is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MINI Cooper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome