Help needed - MINI Cooper Forum
MINI Cooper Diesel MINI Cooper Diesel 2007 - Present

 
LinkBack Thread Tools Rate Thread
post #1 of 9 (permalink) Old Dec 6th, 2009, 10:32 PM Thread Starter
MINI2 Newbie
 
Join Date: Oct 2009
Local Time: 01:59 PM
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)

United Kingdom
 
DIY Help needed

Hey all!

I have had my Cooper D for a month now and I have noticed when the car idles it keeps going to cut off, but dosent. The revs will drop to about 500 then quickly back to 900 ish.

Anyone had this or know what it could be?

Thanks

Karim is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old Dec 7th, 2009, 01:45 PM
still learning
 
Join Date: Feb 2007
Location: near Glasgow
Local Time: 01:59 PM
Posts: 1,270
Mentioned: 0 Post(s)
Quoted: 0 Post(s)

Scotland Male
 
Karim, you don't say how old your car is, has it recently been serviced ?

has it always done this since you got it ?

could be a rubber air intake hose disconnected or leaking.

Iain

iain cooper is offline  
post #3 of 9 (permalink) Old Dec 7th, 2009, 09:31 PM
MINI2 Regular
 
Join Date: Oct 2009
Local Time: 01:59 PM
Posts: 114
Mentioned: 0 Post(s)
Quoted: 0 Post(s)

United Kingdom
 
I have had a Cooper D for three months and mine doesn't do that. Sometimes on cold days when the car isn't propoerly warmed the stop start gets 'confused' and does stopping but not starting, but yours sounds like something different.
IanT is offline  
 
post #4 of 9 (permalink) Old Dec 7th, 2009, 09:58 PM Thread Starter
MINI2 Newbie
 
Join Date: Oct 2009
Local Time: 01:59 PM
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)

United Kingdom
 
Sorry...The car was brand new a month ago. Its currently on about 800 miles and has done it since I have had it. I am tempted to take it back to MINI but i am trying to wait until the run in period is over to see if things get any better.

I was just wondering if anyone has had the same expirence, but dosent look like it. I find it does it more when the car is cold
Karim is offline  
post #5 of 9 (permalink) Old Dec 8th, 2009, 05:42 AM
MINI2 Senior
 
Join Date: Aug 2009
Location: South Coast
Local Time: 01:59 PM
Posts: 640
Mentioned: 0 Post(s)
Quoted: 10 Post(s)

United Kingdom Male
 
Mines a similar age, 6 weeks, and it's never done it. Never had the Auto S/S get confused either (yet!). It won't switch off first thing in morning at the lights cos I assume it's cold and the lights are on etc but I kinda expected that.

IanT, what do you do when it won't start? just depress the clutch again and hit the button??
timp is offline  
post #6 of 9 (permalink) Old Dec 8th, 2009, 07:49 AM
MINI2 Privilege Member
MINI2 Regular
 
55JWB's Avatar
 
Join Date: Jul 2009
Local Time: 01:59 PM
Posts: 135
Mentioned: 0 Post(s)
Quoted: 0 Post(s)

United Kingdom View 55JWB's Dark Silver & Black 2nd Gen MINI Cooper S Diesel Profile View 55JWB's Classified Ads
 
Quote:
Originally Posted by timp View Post
It won't switch off first thing in morning at the lights cos I assume it's cold and the lights are on etc but I kinda expected that.
Correct, its designed to only work when efficient for the engine and warmed up...
55JWB is offline  
post #7 of 9 (permalink) Old Dec 8th, 2009, 11:48 AM
MINI2 Senior
 
Join Date: Aug 2009
Location: South Coast
Local Time: 01:59 PM
Posts: 640
Mentioned: 0 Post(s)
Quoted: 10 Post(s)

United Kingdom Male
 
I wish it would (optionally) kill the headlights - there's something about sitting there with a dead engine and headlights blazing.
timp is offline  
post #8 of 9 (permalink) Old Dec 8th, 2009, 12:16 PM
MINI2 Privilege Member
MINI2 Regular
 
55JWB's Avatar
 
Join Date: Jul 2009
Local Time: 01:59 PM
Posts: 135
Mentioned: 0 Post(s)
Quoted: 0 Post(s)

United Kingdom View 55JWB's Dark Silver & Black 2nd Gen MINI Cooper S Diesel Profile View 55JWB's Classified Ads
 
not sure if they dim? I know the aircon etc dips when it happens...
55JWB is offline  
post #9 of 9 (permalink) Old Dec 8th, 2009, 07:05 PM
MINI2 Senior
 
Join Date: Aug 2009
Location: South Coast
Local Time: 01:59 PM
Posts: 640
Mentioned: 0 Post(s)
Quoted: 10 Post(s)

United Kingdom Male
 
Nope, my Xenons certainly don't dim. Hadn't noticed anything with the aircon.
timp is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MINI Cooper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
help needed...taking dealer to court over repairs wurdup General Discussion 10 May 14th, 2013 07:32 AM
New radiator needed already on '09' plate?? Freddiecider Second Generation Faults & Fixes 13 Apr 25th, 2013 03:52 PM
Mini Cooper S, slight oil leak, helped needed! Lainchers First Generation Faults & Fixes 6 Feb 23rd, 2013 10:24 PM
Bonnet needed! EVM Welcome New Members 2 Aug 2nd, 2012 09:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome