Help No Coolant Reading Showing On Hidden Menu, Cooling Fan On! - MINI Cooper Forum

MINI Cooper Diesel MINI Cooper Diesel 2007 - Present

 
LinkBack Thread Tools Rate Thread
post #1 of 3 (permalink) Old Jul 12th, 2015, 10:05 PM Thread Starter
MINI2 Newbie
 
Join Date: Jul 2015
Local Time: 11:50 PM
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)

 
Help No Coolant Reading Showing On Hidden Menu, Cooling Fan On!

Hi everyone urgent help needed!!!!

Just purchased a mini cooper 1.6d 59 reg, with 99k miles. I noticed right of the hat the cooling fan is constantly on even from cold, however it goes off after 5 minutes from shut down. I checked the hidden data option 7 and the coolant reading is showing ttt0c with no reading from cold and even when warmed up no reading. I do get hot air and a/c is never used.

There is also a hissing noise from brake pedal when depressed.

Can this be related to the whole coolant housing the mechanical thermostat stuck with the combination of a after market temp sensor? Is there another sensor that detects the coolant temp that triggers the fan? I ask because there is NO readings of the coolant temp at all under the hidden menu.

The hissing noise from brake pedal can someone tel me what part i would need?

So far i changed the coolant sensor after market the green bit but nothing changed. Please advise needed.

Syed Ahmed is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Jul 16th, 2015, 09:27 PM Thread Starter
MINI2 Newbie
 
Join Date: Jul 2015
Local Time: 11:50 PM
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)

 
Now fixed, loose wire on coolant sensor caused by rubbing against gear selector and wearing through hence no reading, wire repaired and didn't need to replace coolant housing and sensor but did so anyway as i purchased parts anyway Servo just needed bolts tightening and hey presco running perfect no more fan noise start or stop or hissing noise

Syed Ahmed is offline  
post #3 of 3 (permalink) Old Jul 17th, 2015, 02:14 AM
MINI2 Newbie
 
Join Date: Jul 2015
Location: Ontario
Local Time: 11:50 PM
Posts: 37
Mentioned: 0 Post(s)
Quoted: 4 Post(s)

Canada Male
 
Garage
that is a ***** eh mate? I had to change my housing just a week ago... twice! First one was aftermarket crap and had a bad thermostat the second was from a dealer and all is good now!

good to hear your fix was easier than mine!
Slym is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MINI Cooper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radiator cooling fan issue - resolved cokey First Generation MINI Cooper S 1 Sep 5th, 2018 11:10 PM
hidden menu battery reading genik Second Generation MINI Cooper S 1 Jun 25th, 2014 07:28 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome