Cooper 2007 P0013 and P0014 engine codes. - MINI Cooper Forum
Second Generation MINI Cooper MINI Cooper Late 2006 - Present

 
LinkBack Thread Tools Rate Thread
post #1 of 15 (permalink) Old Jun 16th, 2019, 09:41 PM Thread Starter
MINI2 Newbie
 
Join Date: May 2019
Local Time: 02:46 PM
Posts: 11
Mentioned: 0 Post(s)
Quoted: 7 Post(s)

 
Cooper 2007 P0013 and P0014 engine codes.

Help!
This car had a new timing chain fitted about 4 months ago, when first started cold, it revs up to about 2000RPM and back down several times, then settles down and behaves normally, runs well, but engine light is standing. Have renewed one VANOS solenoid and one cam shaft position sensor. Also tried swapping VANOS solenoids and Camshaft position sensors over. Any ideas what to try next?

Is there a fuse for the VANOS solenoids?

P0013 'B' Camshaft Position Actuator 'A' control circuit/Open Bank 1.

P0014 'B' Camshaft Position - Timing Over-Advanced or System Performance Bank 1.

Thanks in advance for any help or info.


Last edited by Chiffy; Jun 16th, 2019 at 10:37 PM. Reason: question
Chiffy is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old Jun 17th, 2019, 06:53 AM
MINI2 Master
 
Join Date: Apr 2017
Location: down west somewhere
Local Time: 02:46 PM
Posts: 4,382
Mentioned: 19 Post(s)
Quoted: 682 Post(s)

United Kingdom Male
 
when timing chain wa done did they replace the oil control rings in the first journal on camshafts been seeing a few of these popping up making them run retarded as wont hold oil pressure to push the vanos sprocket around, i would do a oil pressure test for a start,
the other code shows a open circuit so would appear to be a electrical issue, worth swapping sensors around see if fault moves, or as they are not very expensive if car done over 70k worth replacing them anyway as will be very worn,,
if not the solonoids then wiring maybe common for wires to get broken around 1ft away from ecu connectors need to strip the cover off it and check the wires, failing that ecu needs checking


good tuners/repairs in southwest uk top guys 01579388980
good tuner/ecu body control clones etc lancaster up north uk DALE PHONE NUMBER 07807 222262 top guy.
mike1967 is online now  
post #3 of 15 (permalink) Old Jun 17th, 2019, 10:37 PM Thread Starter
MINI2 Newbie
 
Join Date: May 2019
Local Time: 02:46 PM
Posts: 11
Mentioned: 0 Post(s)
Quoted: 7 Post(s)

 
Hi Mike1967, thank you for replying, I checked the car this afternoon, I had a feeling with the open circuit that power was not getting to vanos solenoid, I took the electrical connection cap off the solenoid (new one bought on eBay!), oil was immediately evident inside, must be leaking through solenoid, this has probably been shorting out power to the solenoid, replaced it with old solenoid which I exercised to ensure that it was not sticking, seems OK, started car three times, no alarms so far! Maybe I shouldn't purchase spares from eBay!!
Chiffy is offline  
 
post #4 of 15 (permalink) Old Jun 18th, 2019, 06:49 AM
MINI2 Master
 
Join Date: Apr 2017
Location: down west somewhere
Local Time: 02:46 PM
Posts: 4,382
Mentioned: 19 Post(s)
Quoted: 682 Post(s)

United Kingdom Male
 
Quote:
Originally Posted by Chiffy View Post
Hi Mike1967, thank you for replying, I checked the car this afternoon, I had a feeling with the open circuit that power was not getting to vanos solenoid, I took the electrical connection cap off the solenoid (new one bought on eBay!), oil was immediately evident inside, must be leaking through solenoid, this has probably been shorting out power to the solenoid, replaced it with old solenoid which I exercised to ensure that it was not sticking, seems OK, started car three times, no alarms so far! Maybe I shouldn't purchase spares from eBay!!
i'll source new ones from ebay a lot but stick with good comapny's
below link
https://www.ebay.co.uk/itm/2X-VANOS-...4AAOSw03lY75Zy

buying new 15 ones form china really bad move

good tuners/repairs in southwest uk top guys 01579388980
good tuner/ecu body control clones etc lancaster up north uk DALE PHONE NUMBER 07807 222262 top guy.
mike1967 is online now  
post #5 of 15 (permalink) Old Jun 18th, 2019, 10:29 AM Thread Starter
MINI2 Newbie
 
Join Date: May 2019
Local Time: 02:46 PM
Posts: 11
Mentioned: 0 Post(s)
Quoted: 7 Post(s)

 
Hi Mike, Started the car this morning, no revving, no engine codes, Success! Thanks for the link, will get new ones next time they fail.
Chiffy is offline  
post #6 of 15 (permalink) Old Jun 18th, 2019, 02:24 PM
MINI2 Master
 
Join Date: Apr 2017
Location: down west somewhere
Local Time: 02:46 PM
Posts: 4,382
Mentioned: 19 Post(s)
Quoted: 682 Post(s)

United Kingdom Male
 
Quote:
Originally Posted by Chiffy View Post
Hi Mike, Started the car this morning, no revving, no engine codes, Success! Thanks for the link, will get new ones next time they fail.
ideal glad to have helped a tad. i've stopped using ebay from now on so my links will be different from non ebay sources as just got shafted by them and a thieving car breaker on there so much for buyer protection,, after a long phone call the ebay muppet agreed with me that what this seller was doing is wrong but they cannot change it, so they cant change it i cant spend anymore money there or recommend anything off there from here on in,

good tuners/repairs in southwest uk top guys 01579388980
good tuner/ecu body control clones etc lancaster up north uk DALE PHONE NUMBER 07807 222262 top guy.
mike1967 is online now  
post #7 of 15 (permalink) Old Jun 21st, 2019, 09:57 PM Thread Starter
MINI2 Newbie
 
Join Date: May 2019
Local Time: 02:46 PM
Posts: 11
Mentioned: 0 Post(s)
Quoted: 7 Post(s)

 
Hi, another problem I have encountered is that the wing mirrors will not adjust using the control on the door, have swapped it over with my daughters car and both controls work fine, I can't see both door mirror motors not working, possible fuse? any ideas?
Regards
Chris
Chiffy is offline  
post #8 of 15 (permalink) Old Jun 22nd, 2019, 06:32 AM
MINI2 Master
 
Join Date: Apr 2017
Location: down west somewhere
Local Time: 02:46 PM
Posts: 4,382
Mentioned: 19 Post(s)
Quoted: 682 Post(s)

United Kingdom Male
 
Quote:
Originally Posted by Chiffy View Post
Hi, another problem I have encountered is that the wing mirrors will not adjust using the control on the door, have swapped it over with my daughters car and both controls work fine, I can't see both door mirror motors not working, possible fuse? any ideas?
Regards
Chris
common for the wiring between body and door to play up or get broken, pull rubber gaiter back to view wires,, i use a multi meter on 12 volts to find a live feed and to find a earth return as well as either or both circuits could be effected, would also check the fuse box first off, the fuse is F20 below diagram for fuse arrangement ie its the inside car down by your feet picture below shows where ie diagram of all the ecu's and modules etc, open pictures up in picture viewer on laptop can increase size to view
Attached Thumbnails
Click image for larger version

Name:	Screenshot (149).jpg
Views:	5
Size:	38.1 KB
ID:	228675   Click image for larger version

Name:	Screenshot (148).jpg
Views:	5
Size:	44.9 KB
ID:	228677   Click image for larger version

Name:	Screenshot (150).jpg
Views:	7
Size:	43.1 KB
ID:	228679   Click image for larger version

Name:	Screenshot (151).jpg
Views:	6
Size:	65.2 KB
ID:	228681  

good tuners/repairs in southwest uk top guys 01579388980
good tuner/ecu body control clones etc lancaster up north uk DALE PHONE NUMBER 07807 222262 top guy.
mike1967 is online now  
post #9 of 15 (permalink) Old Jun 30th, 2019, 05:55 PM Thread Starter
MINI2 Newbie
 
Join Date: May 2019
Local Time: 02:46 PM
Posts: 11
Mentioned: 0 Post(s)
Quoted: 7 Post(s)

 
Hi Mike,
Another wee problem since vanos solenoids fitted, when first starting, the engine turns over for about 5 seconds before firing, any ideas??
Chiffy is offline  
post #10 of 15 (permalink) Old Jun 30th, 2019, 08:22 PM
MINI2 Master
 
Join Date: Apr 2017
Location: down west somewhere
Local Time: 02:46 PM
Posts: 4,382
Mentioned: 19 Post(s)
Quoted: 682 Post(s)

United Kingdom Male
 
Quote:
Originally Posted by Chiffy View Post
Hi Mike,
Another wee problem since vanos solenoids fitted, when first starting, the engine turns over for about 5 seconds before firing, any ideas??
could be a number of things diagnostic scan first off have a look whats doing what. fuel pressure being one of them, body control module to check immobiliser maybe cas unit is playing up could be a number of things process of method pick things off first off a deep scan etc, live data run on fuel pressure when cranking etc, if car dont crank for 5 seconds then CAS unit would be suss


good tuners/repairs in southwest uk top guys 01579388980
good tuner/ecu body control clones etc lancaster up north uk DALE PHONE NUMBER 07807 222262 top guy.
mike1967 is online now  
post #11 of 15 (permalink) Old Jul 8th, 2019, 09:11 PM Thread Starter
MINI2 Newbie
 
Join Date: May 2019
Local Time: 02:46 PM
Posts: 11
Mentioned: 0 Post(s)
Quoted: 7 Post(s)

 
Hi Mike, Been having a look at what you said, fuel pressure, does this model R56 N12 engine have a HPFP, I have looked at photos on line and can't find a fuel pump which looks like mine, all are from cooper s models, are they the same? My local garage did a scan but nothing found. I have auto doctor which also picks up nothing. What should the fuel pressure be? Any help much appreciated!
Chiffy is offline  
post #12 of 15 (permalink) Old Jul 9th, 2019, 10:33 AM
MINI2 Master
 
Join Date: Apr 2017
Location: down west somewhere
Local Time: 02:46 PM
Posts: 4,382
Mentioned: 19 Post(s)
Quoted: 682 Post(s)

United Kingdom Male
 
Quote:
Originally Posted by Chiffy View Post
Hi Mike, Been having a look at what you said, fuel pressure, does this model R56 N12 engine have a HPFP, I have looked at photos on line and can't find a fuel pump which looks like mine, all are from cooper s models, are they the same? My local garage did a scan but nothing found. I have auto doctor which also picks up nothing. What should the fuel pressure be? Any help much appreciated!
n12 is nothing like the cooper s fueling, no high pressure pump as such does have a electric pump in the fuel tank as part of fuel sender unit below link for ideal to what looks like, on side of fuel rail on engine there is a valve that looks like a tyre one you can hook a petrol pressure gauge on this to monitor fuel rail pressure its the in tank pump that holds the pressure, these pumps do fail over time
https://www.ebay.co.uk/itm/Genuine-U...sAAOSwSdZWd~76

good tuners/repairs in southwest uk top guys 01579388980
good tuner/ecu body control clones etc lancaster up north uk DALE PHONE NUMBER 07807 222262 top guy.
mike1967 is online now  
post #13 of 15 (permalink) Old Jul 9th, 2019, 10:35 AM
MINI2 Master
 
Join Date: Apr 2017
Location: down west somewhere
Local Time: 02:46 PM
Posts: 4,382
Mentioned: 19 Post(s)
Quoted: 682 Post(s)

United Kingdom Male
 
below pic for fuel pressure
Attached Thumbnails
Click image for larger version

Name:	Screenshot (162).jpg
Views:	5
Size:	44.1 KB
ID:	228869  

good tuners/repairs in southwest uk top guys 01579388980
good tuner/ecu body control clones etc lancaster up north uk DALE PHONE NUMBER 07807 222262 top guy.
mike1967 is online now  
post #14 of 15 (permalink) Old Jul 9th, 2019, 10:56 AM Thread Starter
MINI2 Newbie
 
Join Date: May 2019
Local Time: 02:46 PM
Posts: 11
Mentioned: 0 Post(s)
Quoted: 7 Post(s)

 
Mike, Thank you again! I see the fuel pressure test point, any idea where I can get a gauge to check pressure? Changing the pump seems fairly strait forward. I presume the delay in firing is because the pump is not retaining or producing working pressure? Sorry for being such a pain with all these questions, but you are such a great help!
Chiffy is offline  
post #15 of 15 (permalink) Old Jul 9th, 2019, 11:03 AM
MINI2 Master
 
Join Date: Apr 2017
Location: down west somewhere
Local Time: 02:46 PM
Posts: 4,382
Mentioned: 19 Post(s)
Quoted: 682 Post(s)

United Kingdom Male
 
Quote:
Originally Posted by Chiffy View Post
Mike, Thank you again! I see the fuel pressure test point, any idea where I can get a gauge to check pressure? Changing the pump seems fairly strait forward. I presume the delay in firing is because the pump is not retaining or producing working pressure? Sorry for being such a pain with all these questions, but you are such a great help!
below link cheapest you can go would do the job i would think i have a 250 kit myself so i dont use whats in this link but ot looks like it has got a lot of connectors at worst you might need to find something to match up but that said it looks like its got a type valve type snap connector in that kit
https://www.ebay.co.uk/itm/Benzin-Dr...gAAOSwF0hc-TDW

good tuners/repairs in southwest uk top guys 01579388980
good tuner/ecu body control clones etc lancaster up north uk DALE PHONE NUMBER 07807 222262 top guy.
mike1967 is online now  
Sponsored Links
Advertisement
 
Reply
Tags: ,


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MINI Cooper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome