MINI Cooper Forum banner

1 - 5 of 5 Posts

Registered
Joined
5 Posts
Discussion Starter #1
Hello, I've just recently "upgraded" from a r50 to an 07 plat cooper.

Shortly after i brought it, i replaced the spark plugs, air filter, thermostat & no 3 coil as it was causing a misfire.

Now after several weeks of ownership i still have the following faults:

1. Going through around a litre of oil every 300-600 mile, i know they "use" oil but surely that is a lot?!

2. Hesitation/misfire at motorway speeds, does do it constantly on my journey to work, it is worrying, has triggered and engine management light once, went straight off.

3. very tappety on start up, along with engine whine when pulling away, doesn't sound like a decent car should!

4. Happened once, possibly due to low oil, engine bogged when i came to halt, i had keep the revs up to stop it from cutting out.

Anyone had the same experience before? Something tells me I've brought a bit of a lemon! 馃槀

Thanks Jack
 

Registered
Joined
7,173 Posts
Hello, I've just recently "upgraded" from a r50 to an 07 plat cooper.

Shortly after i brought it, i replaced the spark plugs, air filter, thermostat & no 3 coil as it was causing a misfire.

Now after several weeks of ownership i still have the following faults:

1. Going through around a litre of oil every 300-600 mile, i know they "use" oil but surely that is a lot?!

2. Hesitation/misfire at motorway speeds, does do it constantly on my journey to work, it is worrying, has triggered and engine management light once, went straight off.

3. very tappety on start up, along with engine whine when pulling away, doesn't sound like a decent car should!

4. Happened once, possibly due to low oil, engine bogged when i came to halt, i had keep the revs up to stop it from cutting out.

Anyone had the same experience before? Something tells me I've brought a bit of a lemon! 馃槀

Thanks Jack
how many miles has it done,
 

Registered
Joined
7,173 Posts
could try this buy some seafoam and add 1/4 can to engine oil drive if for 30 miles then do oil and filter change, if its a gummed up piston rings are so many get like this should help remove the glaze on the bores and any dirt causing it, valve stem seals are very common as made of rubber the rubber gets so hot goes hard this causes oil to drop down to stem on valves and car will smoke on over runs and when car been sat idling for 20 minutes give throttle a good rev while watching the exhaust for smoke any smoke more likely valve stem seals, head off job if piston rings head off sump off and pistons out, parts wise worst case 拢600 plus 3 days of labour, best case 拢25 of seafoam,, also can once change oil add 1/4 can of seafoam in new oil this will over time prevent bores glazing and causing blow past, also could try stop leak this can smell valve stem seals back to working again over time ie 1000 to 5000 miles say,
stop leak below
seafoam below,
 
1 - 5 of 5 Posts
Top