MINI Cooper Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
I have a mini cooper s conv 2005 and wanted to update the sat nav disc from the 2001 disc in it, so I bought the 2008-1 professional eurpoe disc. It would appear that the disc doesn't work, I have been told that I need the High version o the disc. Can anyone help me out and give me some advice. :confused:
 

·
Registered
Joined
·
74 Posts
I have a mini cooper s conv 2005 and wanted to update the sat nav disc from the 2001 disc in it, so I bought the 2008-1 professional eurpoe disc. It would appear that the disc doesn't work, I have been told that I need the High version o the disc. Can anyone help me out and give me some advice. :confused:
That is correct you need the "High" version. The Professional will work in the 2nd Gen mini's only.
 
1 - 2 of 2 Posts
Top