MINI Cooper Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
When accelerating our 2010 Mini 1.6 D gets to 2300 revs it gives a severe jolt, it's like switching the key off and on really quickly. It happens when it up to running temp, it accelerates smoothly up to 2300 gives a big jolt then continues on smoothly. There are no fault codes and a local highly qualified technician has scanned and looked until he is 'blue in the boat race' he is completely baffled.

Does anyone have a fix for this problem, please.
 

·
Registered
Joined
·
7,673 Posts
have seen fuel pump reg valves go sideways before do the same thing, also throttle pedal has a dead spot maybe, , is your car pre march or post march ie psa engine or bmw n47
might even be a faulty rail pressure sensor live data while being driven see if pressure die off etc,, the pedal could be probed with a scope on signal wire see if has a dead spot perhaps,
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Thanks for replying, It's a PSA engine, I have already been told it WAS a pedal fault, but changed it to no avail. I have been thinking maybe the throttle body is faulty, I would like to get it connected to a scope rather than just replacing it. I will ask the tech if he can run a live data scan. It is so strange that it only happens at the same revs and nowhere else in the whole rev range.
Thanks again mike1967
 

·
Registered
Joined
·
7,673 Posts
need to scan it might be a sticking vnt common on cars that have had dpf problems the blocked dpf filter stops soot from leaving the vnt in turbo,, you could get screw driver on the lever on the turbo and some freeing oil and push it down wards any notch y feeling then chances are its soot in side.. if it does stick at a point the ecu will see a mismatch to boost demanded and boost given as such this can throw a partial limp event when it dont fulling go in to limp mode it recovers its self
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
Thanks for the suggestions mike1967, I tried VNT which is moving freely. I have used Ista+ which showed no faults, the fault has never brought the EML on. Do you know of software that could be used as the car is driven so maybe a fault might be caught.
 
1 - 5 of 5 Posts
Top