MINI Cooper Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
2008 non cooper 1.6. Had the 2845 fault code. Car when cold is fantastic, when hot it stalls, its lumpy and flat. So far I have replaced both vanos drives, timing chain and upgraded tensioner/guides, thermostat, adaptions reset countless times, and had software updated at BMW. STILL shows 2845 fault code. Getting bored of it now. Chain & tensioners done by a mini specialist, who took it apart again to check everything. Car runs very rich, and is not getting more than 25mpg.

Any clue as to what to do next?
 

·
Registered
Joined
·
52 Posts

·
Registered
Joined
·
5,524 Posts
2008 non cooper 1.6. Had the 2845 fault code. Car when cold is fantastic, when hot it stalls, its lumpy and flat. So far I have replaced both vanos drives, timing chain and upgraded tensioner/guides, thermostat, adaptions reset countless times, and had software updated at BMW. STILL shows 2845 fault code. Getting bored of it now. Chain & tensioners done by a mini specialist, who took it apart again to check everything. Car runs very rich, and is not getting more than 25mpg.

Any clue as to what to do next?
the clue is in when its cold it runs fine,, the 02 sensors are only switched on when engine gets to running temps then it goes in to a closed loop running so i would guess its a intermittent 02 sensor or wiring to and from it maybe or cat is warn out form oil use or not being driven hard enough to keep it clean as such word of warning only use genuine 02 sensors as chep ones are rubbish
 

·
Registered
Joined
·
5,524 Posts
also on 1st cam shaft journal there are oil control rings within them the early cars had metal ones bmw changed this is on later cars to nylon carbon plastic ones when these wear out its prevents the vanos sprocket to rotate the oil bleeds off ..its possible to use a camera on a cable and can see the oil spraying out of the cam journal when faulty,, also the oil when gets hot gets thinner and this could be why it only does it when engine hot, or you could have two faults ie 02 sensors as well
 
1 - 4 of 4 Posts
Top