MINI Cooper Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all , having trouble with abs light an tyre pressure light ( on solid ) recently changed pads an discs on front ( mini r50 2002) an wheel bearing . I believed I have damaged a wheel sensor when trying to remove it when fitting new wheel bearing which I believe has caused the abs light .. also my brake fluid is very dark brown . My brakes are very poor which I can understand as the brakes are bedding in however I have only purchased this car an brakes were very poor . The brake pedal is very spongy . Any help would be amazing have you encountered this problem before ??
 

·
Registered
Joined
·
6,638 Posts
its common on gen 1 cars for abs pump/ecu to pack up they are one unit, if light came on right after doing the work you have done then prob some thing that not went back right,, as for brake fluid its meant to be changed every 4 years max , use a easy bleed system is best way lik below for a good one and its cheap as well you will need dot4 brake fluid,
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
its common on gen 1 cars for abs pump/ecu to pack up they are one unit, if light came on right after doing the work you have done then prob some thing that not went back right,, as for brake fluid its meant to be changed every 4 years max , use a easy bleed system is best way lik below for a good one and its cheap as well you will need dot4 brake fluid,
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Thank you for the reply . Think I’ve sussed it now . I had damaged a wheel speed sensor . I’ve fitted a new one an the lights have gone out however brakes are still spongy an poor . I’m going to bleed the brakes all round tommorow morning hopefully this will do the trick . Thanks again :)
 
1 - 5 of 5 Posts
Top