MINI Cooper Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi there

I have a mini one and tried to use the air conditioning at the weekend but the button was dead (no light)

I checked other buttons on that panel and found that also the rear windscreen heater button and the air circulation buttons do not work either.

There is electricity going to the panel, as when you switch the lights on the panel does light up, but still the buttons do not work

I checked the fuses and they are ok, but did notice strangely that the fuse F10 - heated front windscreen is missing? Could this be the problem? Should my mini have this fuse?

Any help or advice would be appreciated as with no aircon I am cooking in the car!
 

·
Derv? Nein Danke.
Joined
·
130 Posts
Silly question ................. but ........................ was the fan switched on??

I had the same problem (so I thought) but the wife pointed out that unless the fan is turned on the ac won't switch on. :biggrin:
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Yep fan is on, and working fine, but no air con

I Luckily after much nagging I have managed to get it into the mini garage on Friday.

So will let you know what it is?!
 

·
Registered
Joined
·
5 Posts
The stealership replaced 2 modules cost me over 3 thousand dollars, but it is too hot here in Australia to drive around with no air
 

·
Registered
Joined
·
5 Posts
Ok thanks for your information. And I understand that you need it in Australia :).
I just looked at the paper work and the A2 module part number 62109126993 was not responsive and when that was replaced the general module failed part number 61356982114 also became unresponsive mine is a 2004. Both were replaced and everything works fine
 
1 - 9 of 9 Posts
Top