MINI Cooper Forum banner
1 - 3 of 3 Posts

·
JcwMiniAdventures
Joined
·
434 Posts
Discussion Starter · #1 ·
Your adavice needed again for the next two problems please

PROBLEM 1
I wondered if any one has the same problem/can give me some advice on the problem i have with my MCS rear washer

My washer failed the other week & has been replaced with a new motor/pump which was fitted last weekend - was working fine one day - then went to use the following day & nothing - the new pump has gone again.

I realise to test it again i'm prob going to have to get another motor/pump but @ £25+ a time its not cheap for no garantees for the same thing to happen again

We have decided there's a connection fault somewhere but not sure how to fix & am very reluctant to pay BMW labour prices

Any ideas what could be causing this & how we can go about fixing it

My Brother is a mechanic & he got no ideas


PROBLEM 2

Does anyone have/ i can buy/know where to get hold of some windscreen bonding sealant glue stuff

I need to get hold of some to re-bound my windsreen strip
I have been on to RAC & they want me to pay £100+ to remove my whole widscreen to re-bound the seal with NO GUARTEES that they wont break it & @ £200 for a new windscreen WHEN THERE IS NOTHING WRONG WITH IT - ITS JUST THE STRIP - I am lumping it at the mo.

My bruv did have some but its gone hard & when doing 50-60mph its comes unstuck

Also its going to be dangerious driving on the motorway like it is is so trying to get it fixed ASAP but having no joy.

Any adavice on both the above please

Cheers
 

·
JcwMiniAdventures
Joined
·
434 Posts
Discussion Starter · #3 ·
Cheers for that mab01uk - thats sound like what i need - i will get my brother to have a go when its stope's raining

Thanks buddy
 
1 - 3 of 3 Posts
Top