MINI Cooper Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I get a really bad random misfire at a cold start up on my 09 john cooper works. I’ve replaced spark plugs,coils,fuel pump,fuel filter. Idk to look other then injectors or my hpfp. I’m looking for ideas to move forward to fix this problem.
 

·
Registered
Joined
·
11,872 Posts
when high pressure fuel pump fails it will cause misfires on first cold start up , need to live data the pressure on first start up, if should be 5mba if see under this and then when car runs with no misfires you see pressure rise again it will be high pressure pump,, what happens the seals go hard in time and allow air in to system when car parked up,, so when first starts its takes time for the air to be pushed out again, almost like running out of fuel
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
when high pressure fuel pump fails it will cause misfires on first cold start up , need to live data the pressure on first start up, if should be 5mba if see under this and then when car runs with no misfires you see pressure rise again it will be high pressure pump,, what happens the seals go hard in time and allow air in to system when car parked up,, so when first starts its takes time for the air to be pushed out again, almost like running out of fuel
Okay so will it be fine to drive it like this this I get a new hpfp. Won’t cause damage to the engine?
 

·
Registered
Joined
·
11,872 Posts
would get it fixed asap my self,
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
when high pressure fuel pump fails it will cause misfires on first cold start up , need to live data the pressure on first start up, if should be 5mba if see under this and then when car runs with no misfires you see pressure rise again it will be high pressure pump,, what happens the seals go hard in time and allow air in to system when car parked up,, so when first starts its takes time for the air to be pushed out again, almost like running out of fuel
So I replaced my hpfp and it’s almost running worst on cold start ups now. Struggling to get started sometimes. Takes 3 to 4 starts and revs to get it running. It also goes into like limp mode for the first couple of mins of driving. But goes away after I shut it off and restart it. It then runs like a champ with like more power then before the replacement tho. Idk where to go after this. Any ideas?
 

·
Registered
Joined
·
11,872 Posts
So I replaced my hpfp and it’s almost running worst on cold start ups now. Struggling to get started sometimes. Takes 3 to 4 starts and revs to get it running. It also goes into like limp mode for the first couple of mins of driving. But goes away after I shut it off and restart it. It then runs like a champ with like more power then before the replacement tho. Idk where to go after this. Any ideas?
see all that you just said on 10 cars that do that on start up nearly all were high pressure fuel pump, beware of cheap ebay china so called new pumps that are just used pumps cleaned up, unless fit a new known working pump you could very well be moving a problem in , another weak point is thermostat housing , and once again fitting anything less than febi or genuine dont tend to end well
 
1 - 8 of 8 Posts
Top