MINI Cooper Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi
I have a 2007 cooper s which has the following mods
AEM air intake
Forge intercooler

I have been having cold start issues for some weeks now. Sometimes I have to start the car 4-5 times before it will run - otherwise just dies. Even when started the car is very hesitant and will clog up if I try hard acceleration. During this time the car pops n bangs like a good un :) Although the car is much better when warm I still get the odd missfire even then
I do not get any EML on the dash
Any ideas where to start?
 

· Registered
Joined
·
13,582 Posts
temp sensor first place, after that 02 sensor, more expensive timing chain stretched,
diagnostics live data scan on coolant temp ie car cold 15c to 20c should be correct if see 30c or above then sensor or car ecu at fault, then from cold live data run watch the temp increase it should just creep up from 20c ish up to around 105c when hot,
 

· Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Thanks mike
Funnily enough I had a coolant leak few weeks back so replaced thermostat housing which includes temp sensor I think? Also had timing chain replaced whilst in. Cold start issue was there before and after this work.
 

· Registered
Joined
·
13,582 Posts
so you need to put volt meter on temp sensor at 20c it should read around 2,8 to 3.2volts and reduce as car gets hotter, might find if coolant leak has been there for a while the coolant will like a sap on a plant work way up the coated cables to the cars ecu or if not got that far it can alter the resistance in the wires them selves and change how the signal wire is read by the ecu,, ie ecu wants a set voltage at set temps or running,
also if you have fitted a aftermarket housing chances are its this that is the issue the cheap ones are total rubbish they also if barely work within a parameter cause engine over time to run to hot and thin oil and cause crankshaft issues further down the road , in fact on psa and mini there is a recall on thermostat housings due to cracking and piloted housing failures and running t hot causing bigger issues etc ,, ie a 4 pin housing with a wiring update complete in kit link below is latest and genuine housing

also if fitting 02 sensors make sure its a genuine Bosch or uk branded item
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top