MINI Cooper Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Evening all - long time lurker in need of some help, please.
2007 Mini Cooper S r56 in generally good health. Driving for a couple hours this afternoon on the motorway in rain at motorway speeds.
Suddenly some beeping and warning light messages appear stating various issues: restraint system failure, ABS, brakes and the windscreen wipers stopped mid-sweep.. naturally panic ensued!
Managed to find a way through to the hard shoulder as steering became very heavy - can't recall if the engine cut-out or if I turned it off myself because of fear of engine fire (noticed a slight plastic melting smell). Attempted to start engine and nothing at all.. no attempt to turnover at all.

Called the AA roadside assistance out who read the errors that seemed to related to electrical power issues (Engine control - 1LC / Motronic ME 17 Status: 2C91 - voltage monitoring - "Undervoltage") - upon clearing the errors we were able to start the engine. He checked that the alternator was charging up the battery sufficiently and that the battery level was good. Managed to drive home for another 40mins without subsequent issue though seeing some additional errors (see report attached).

Any thoughts on the cause please - have a fuse or ECU fried? Currently very worried to even consider letting my family take the car out.

FYI - about a month ago I replaced:
- Timing chain, tensioner, crank seal, guides, bolts
- VANOS (intake)
- Auxillary belt - confirmed still in place and fine

Many thanks!
 

Attachments

·
Registered
Joined
·
5 Posts
Discussion Starter #2
Just to close this thread - it actually turned out to be a poor engine ground connection. Simple but took a while to work out!
 
1 - 2 of 2 Posts
Top