MINI Cooper Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hi guys, my Mini One's yellow engine warning light came on last night, and I found the coolant tank completely empty. But the temperature indicator didn't show the car as being overheated. I filled the coolant this morning but the engine light stays on. I know many 2006 models had the coolant tank problem but mine had it fixed by Mini dealer a couple of years ago, and it never had any problem. I had a full service with Halford Autocentre a few weeks ago. As soon as I left the garage I heard a strange water flowing sound coming from under the dashboard, like there was half bottle of water there. The sound was obvious, and the car never had it before. The screenwash they filled in my car was in blue colour and could never wipe clean. I probably shouldn't have ignored the issues at that point. Thinking about it now I suspect they put screenwash in my coolant tank and coolant in screenwash tank. Not sure what I should do now and whether my engine has been damaged. Any ideas? I'm thinking of going to another dealer to check why engine light came on and whether anything was damaged by the full service, and get an assessment report if I need to claim compensation. Am I too nervous?

Thanks!
 

·
Registered
Joined
·
278 Posts
Hi. Are you with the AA, if you are you could give them a shout.
I've seen what happens when coolant is put in the screen wash and it's as you say, just smears and no way will it clear the screen. Thermostat housing may be leaking, so check under the plastic housing to see if it's wet.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
Hi. Are you with the AA, if you are you could give them a shout.
I've seen what happens when coolant is put in the screen wash and it's as you say, just smears and no way will it clear the screen. Thermostat housing may be leaking, so check under the plastic housing to see if it's wet.
Thanks! The engine warning light came off today. Checked coolant level and it was 2cm below where it was yesterday. Checked after a short drive but it wasn't wet under the thermostat housing. I will take it to a local garage this weekend. Unfortunately I forgot to renew my AA last month...
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
Anyone else also having the water flowing sound when starting the car? I don't think mine had it before the service...
 
1 - 4 of 4 Posts
Top