MINI Cooper Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
134 Posts
Discussion Starter · #1 ·
I am hoping someone will be able to put my mind at rest .

I took my 2003 R53 to my local handwash where they use a jet wash to clean the cars .

Long story short , sat waiting for the guy to finish going over my car turn my engine on to move the car and I notice my engine temp FLY up as if the car was overheating . I quickly turn the engine off and wait for the guys to completely finish cleaning my car .Upon turning the engine back on I notice a LOT of steam coming from the vent on the front of the car and the engine temp flies up again . As I have to move my car I drive off a few feet and stop and shut down the engine .I leave it a few minutes start the car back up again and the engine temp stays at normal and everything stays ok .Drive the car back home 10 mins away from the car wash and everything is still fine .

Before anyone asks , I filled the coolant and checked the oil etc last week .

Is it possible that when washing the car with the jet wash water got in through the scoop and my car was just reacting to that ?
Completely baffled here and a little worried !
Any advice is more than welcome ( plz bear in mind I am useless at anything mechanical )
 

· Registered
Joined
·
21 Posts
I'm thinking a connector got a bit wet & an erroneous signal (or lack of one) was interpreted as high temperature?

Re the steam, I guess it was just bits (radiator, exhaust manifold etc) also getting wet & drying out quickly ... however I think I'd be looking at coolant levels carefully fr the next few days in case they've blasted a hole in the rad (or a bit of rust that was holding the coolant in)...

:)
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top