MINI Cooper Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi all,

I'm the happy new owner of an '04 Mini Cooper, with factory navigation. It seems to work fine , although it's in need of an OS update, and a newer map disk. There is one thing that concerns me: the nav screen has a noticible (sometimes very noticible) flicker.

Any idea what is causing this, and how to fix it? :puzzled: I searched before posting, and didn't find anything.

Thanks in advance!

Susan
 

·
MMC Member
Joined
·
14,017 Posts
This is not normal at all. It sounds like a loose connection of some sort. Hate to say this, but a trip to the dealer or an audio video specialist is probably required.
 

·
Registered
Joined
·
727 Posts
There are 3 connectors between the NAV computer under the seat and the display in the dash.

1. @ the navigation computer on the back of it under the seat.
2. near the fusebox in the LHS footwell
3. @ the back of the display in the dash

suggest you check these 1st.
 

·
Registered
Joined
·
19 Posts
r u running on stock power cables or have u swapped them for performance ones? ie Nology power cables. Reason being, a friend of mine had the same problem and found that it was the culprit.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Thanks for your replies! I'll definitely check the connections before going to the dealer. The wiring is the original from the factory.

Again, I appreciate the advice, thanks for your help! :red:
 
1 - 5 of 5 Posts
Top