MINI Cooper Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
New to forum so hello everyone

Right I have a 2003 Mini Cooper
Was running fine until I went to go home and it wasn’t getting any fuel. pump was my thought as already had done filter so got second hand one still didn’t help so checked filter for some reason rubber seals had broke so got a new one and after priming it started wooooohoooo
Nope next morning came out wouldn’t start unless turned on and off to re prime and this has carried on I’ve checked connections all seem fine what am I missing fellow mini drivers cause I’m at end of my rope with it.

Thanks in advance Dan
 

·
Registered
Joined
·
6,241 Posts
New to forum so hello everyone

Right I have a 2003 Mini Cooper
Was running fine until I went to go home and it wasn’t getting any fuel. pump was my thought as already had done filter so got second hand one still didn’t help so checked filter for some reason rubber seals had broke so got a new one and after priming it started wooooohoooo
Nope next morning came out wouldn’t start unless turned on and off to re prime and this has carried on I’ve checked connections all seem fine what am I missing fellow mini drivers cause I’m at end of my rope with it.

Thanks in advance Dan
rubber seals broke on fuel filter ?
1. cheap filters are known to cause issues ie the paper part break down and block injectors at worse
2 and rubber seal in the fuel line that break down could send parts of it down stream and block things up.
i would put air line on one end of fuel pipe and blow through it make sure nothing has blocked things up. also need to diagnostic scan it check live data for fuel pressures will give clues to where the issues are,
 
1 - 2 of 2 Posts
Top