MINI Cooper Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter · #1 ·
After a bit of reading of old threads such as http://www.mini2.com/forum/exterior/109341-xenon-hid-extreme-white-sidelight-bulbs-2.html

and looking at some pictures from other members cars, I have Just ordered some of these below from Autobulbsdirect.co.uk

Product here: LED Extreme Power - NEW! :: Autobulbs Direct Ltd - Xenon bulbs, car bulbs, wiper blades, headlight, Osram, Ring, Philips

Cost about £10 inc. delivery if ordered via the ebay shop. Will get some pics up as soon as they arrive. Im hoping for something to match the colour of the Xenons!

Pic's to follow when they arrive.... !
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #2 ·
Well, fitted these today and they are a great match for the Xenons. Much better than the standard yellowie bulbs!

Attached a couple of pics for those interested. Sorry about the quality.



 

·
Registered
Joined
·
988 Posts
Wicked! They look great! Are they difficult to fit? I've never actually looked at how to replace the sidelights.

What indicator bulbs do you have?
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #10 ·
put them in my r56, just kept upsetting the car. kept coming up with light fault. very unhappy.
Have read in another thread somewhere that changing the sidelights to leds in the r56 always results in the fault light thing!
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #11 ·
Wicked! They look great! Are they difficult to fit? I've never actually looked at how to replace the sidelights.

What indicator bulbs do you have?
2 second job, twist out, replace, twist in!

Only got the standard orange indicators at the mo :(
 

·
Noob
Joined
·
247 Posts

·
Noob
Joined
·
247 Posts
Woohooo!

Please ignore my previous post. I wonder if I can delete the post altogether?

I have just got it running. I tried again .. actually, I tried a few times. I took the little LED out and put it back in several times, and it's now working.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #14 ·
Woohooo!

Please ignore my previous post. I wonder if I can delete the post altogether?

I have just got it running. I tried again .. actually, I tried a few times. I took the little LED out and put it back in several times, and it's now working.
As you have probably discovered, they have a + & - side so they have to be round the correct way! :D
 

·
Noob
Joined
·
247 Posts
As you have probably discovered, they have a + & - side so they have to be round the correct way! :D
I'm sure I've got the exact same bulbs. I actually paid more by getting them from NewMiniStuff rather than eBay, however I really don't think mine are as bright as yours. Does it take awhile to get that bright?
 
1 - 15 of 15 Posts
Top