MINI Cooper Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hello All!

I have a Mini R56 1.6 Cooper 56 plate; I have had the car for about five years and have sorted all the common issues with this generation of mini; the car has 94,000 miles, and since I last serviced it, it has been running fine until now. The recent problem I've been having is the headlights seem to be flickering whilst driving at night; what also happens is when I change gear up or down the headlights, and all the electrics inside the car will flick off and back on, and it also causes the steering warning light to come on momentarily as well, this seems to only happen when I am driving with the headlights on and occasionally while they're off. I've never had this happen before and I am not the best at diagnosing electrical issues. I am inclined to say it is the battery as I changed that when I brought the car, the car also stood for about 7-8 months as I had use of another vehicle, so that more than likely did not do the battery any favours. Basically, I am asking, is it a battery issue? from my experiences, it would suggest it is a battery issue but I thought I'd ask the forum to get some opinions on the matter before trying anything. I'm all ears to ideas for fixing this issue and appreciate all the help
Thank you!
 

·
Registered
Joined
·
190 Posts
Hello All!

I have a Mini R56 1.6 Cooper 56 plate; I have had the car for about five years and have sorted all the common issues with this generation of mini; the car has 94,000 miles, and since I last serviced it, it has been running fine until now. The recent problem I've been having is the headlights seem to be flickering whilst driving at night; what also happens is when I change gear up or down the headlights, and all the electrics inside the car will flick off and back on, and it also causes the steering warning light to come on momentarily as well, this seems to only happen when I am driving with the headlights on and occasionally while they're off. I've never had this happen before and I am not the best at diagnosing electrical issues. I am inclined to say it is the battery as I changed that when I brought the car, the car also stood for about 7-8 months as I had use of another vehicle, so that more than likely did not do the battery any favours. Basically, I am asking, is it a battery issue? from my experiences, it would suggest it is a battery issue but I thought I'd ask the forum to get some opinions on the matter before trying anything. I'm all ears to ideas for fixing this issue and appreciate all the help
Thank you!
I had random electrical issues recently, windscreen wipers stopped working intermittently then random warning lights and finally the dashboard lit up like a disco and the car ground to a halt. I thought it was the battery,. Charged it up and when checking the voltage at the battery was only getting 11 volts when you should be getting more like 14. Replaced the alternator with a refurbished one and it's run perfect since.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
I had random electrical issues recently, windscreen wipers stopped working intermittently then random warning lights and finally the dashboard lit up like a disco and the car ground to a halt. I thought it was the battery,. Charged it up and when checking the voltage at the battery was only getting 11 volts when you should be getting more like 14. Replaced the alternator with a refurbished one and it's run perfect since.
I'll have to check the battery voltage when running to see if its alternator but that is a good suggestion!
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top