MINI Cooper Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi everyone urgent help needed!!!!

Just purchased a mini cooper 1.6d 59 reg, with 99k miles. I noticed right of the hat the cooling fan is constantly on even from cold, however it goes off after 5 minutes from shut down. I checked the hidden data option 7 and the coolant reading is showing ttt0c with no reading from cold and even when warmed up no reading. I do get hot air and a/c is never used.

There is also a hissing noise from brake pedal when depressed.

Can this be related to the whole coolant housing the mechanical thermostat stuck with the combination of a after market temp sensor? Is there another sensor that detects the coolant temp that triggers the fan? I ask because there is NO readings of the coolant temp at all under the hidden menu.

The hissing noise from brake pedal can someone tel me what part i would need?

So far i changed the coolant sensor after market the green bit but nothing changed. Please advise needed.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Now fixed, loose wire on coolant sensor caused by rubbing against gear selector and wearing through hence no reading, wire repaired and didn't need to replace coolant housing and sensor but did so anyway as i purchased parts anyway :( Servo just needed bolts tightening and hey presco running perfect no more fan noise start or stop or hissing noise :)
 

·
Registered
Joined
·
37 Posts
lol that is a ***** eh mate? I had to change my housing just a week ago... twice! First one was aftermarket crap and had a bad thermostat the second was from a dealer and all is good now!

good to hear your fix was easier than mine!
 
1 - 3 of 3 Posts
About this Discussion
2 Replies
2 Participants
Slym
MINI Cooper Forum
Join our Mini Cooper Forums to talk about your new Mini. From reviews, mods, accessories, reliability concerns and more, this Mini Owners Club is full of info!
Full Forum Listing
Top