MINI Cooper Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
Hey Guys,

My name is Jonathan, I'm from Sydney, Australia and I recently purchased (on Friday) an 07 R56 Cooper S fully loaded with options - including the Sat Nav.

On occasion, the 'Accept' screen on the iDrive (the first thing you see when you turn on the car) fails to exit to the main screen. Normally you will press the joystick and it will accept and move on to the main menu. I can still hear the radio, cd, switch between the two and also receive calls via bluetooth (without display) adjust volume and switch tracks / radio stations - but the screen sits on 'Use this when safe etc. etc.

The only fix for me right now is turning off the car for a 5 minute period and hoping it works next time I start her.

Has anyone experienced anything like this?

An unrelated issue, when I was giving her a good run last night in Sport mode the car seemed to drop to normal mode and popped up with 2 lights on the taco. 1 was a red light which looked like this (!) and the other was a yellow ! with an arrow around it (i think). Anyone know what this means? It went away after 30 seconds of normal driving and returned to Sport mode automatically.

Thanks for the help!

Look forward to joining this community :)
 

·
just hanging round
Joined
·
8 Posts
hey mate, im also on ausmini ;)
i think the lights you saw were thee tyre pressure and traction coontrol, which also explains your problem.

when the traction light came on, it would have taken some power away from you, all it means is the car is having trouble getting traction, turn it off and have some fun!
and the otehrlight i think is teh tyre pressure light, give them a check and see what theyre doing,

jamie
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #3 ·
hey mate, im also on ausmini ;)
i think the lights you saw were thee tyre pressure and traction coontrol, which also explains your problem.

when the traction light came on, it would have taken some power away from you, all it means is the car is having trouble getting traction, turn it off and have some fun!
and the otehrlight i think is teh tyre pressure light, give them a check and see what theyre doing,

jamie

Hey mate, thanks for the reply :)

I wasn't making the traction control work though? I was giving it but I made no attempt to break traction, not even around the corners - I was just sitting steady and accelerating out. If it was also the Tyre Pressure warning wouldn't it remain? I hope this isn't the start of electrical gremlins as that's the main reason I got rid of my damn Alfa and got the Mini!

Is there an online resource for R56 warning lights and what they mean? I haven't got my User Manual on me..

Edit: Just found an online manual, looks like it was those lights (ASC + Tire Monitor). Do you think I should have these checked?
 

·
Registered
Joined
·
53 Posts
Hey mate, thanks for the reply :)

I wasn't making the traction control work though? I was giving it but I made no attempt to break traction, not even around the corners - I was just sitting steady and accelerating out. If it was also the Tyre Pressure warning wouldn't it remain? I hope this isn't the start of electrical gremlins as that's the main reason I got rid of my damn Alfa and got the Mini!

Is there an online resource for R56 warning lights and what they mean? I haven't got my User Manual on me..

Edit: Just found an online manual, looks like it was those lights (ASC + Tire Monitor). Do you think I should have these checked?
The ASC system kicks in to prevent loss of traction so if the car senses even slight loss of traction it will kick in and the light will come on. i used to get the traction light come on during hard acceleration in 2nd. best remedy is to turn it off ;)

Take it in to the dealer for a check anyway since it sounds like your satnav is not working properly.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #5 ·
The ASC system kicks in to prevent loss of traction so if the car senses even slight loss of traction it will kick in and the light will come on. i used to get the traction light come on during hard acceleration in 2nd. best remedy is to turn it off ;)

Take it in to the dealer for a check anyway since it sounds like your satnav is not working properly.
Thanks for the reply e34 ;)

I understand the light coming on momentarily when the ASC system kicks in. What I don't understand is why both these lights would stay on permanently for 30 seconds whilst driving at 60km/h and in a straight line :confused: On top of that the engine died in the ass :mad:
 
1 - 5 of 5 Posts
Top