MINI Cooper Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey there, for about a month now I've been having this issue with the highbeams on my 2002 r53. Basically I have no control over the highbeams whatsoever, they will come on randomly and they will only turn off if I turn the headlights on and off. I can't manage to turn them on using the switch 99% of the time. I checked the fuses for the headlights (I didn't see one for the highbeams) and they are fine. There's no relay. The bulbs are fine. Last resort is to change the switch itself which wouldn't be expensive nor difficult (I think, but it is a mini so...) but I figured I'd make a post and see if anyone knew what this could be or if anyone has encountered it before. Luckily my highbeams aren't too bright and they're pointed pretty down so when they come on in traffic they aren't too bothersome to other drivers but when they are flashing on and off as they do some times I worry about annoying others on the road so I need to get them fixed asap.
 

·
Premium Member
2008 Mini Cooper S hatchback,Automatic,Mello Yellow
Joined
·
1,018 Posts
There is question I would have to ask!
Are you running Xenon lights?
Xenons going out might present a ballast control module issue.
On a off note they do sell the switch unit completely. But if it appears to be in good physical shape it probably is
In my opinion.
 

·
Registered
Joined
·
9,605 Posts
Hey there, for about a month now I've been having this issue with the highbeams on my 2002 r53. Basically I have no control over the highbeams whatsoever, they will come on randomly and they will only turn off if I turn the headlights on and off. I can't manage to turn them on using the switch 99% of the time. I checked the fuses for the headlights (I didn't see one for the highbeams) and they are fine. There's no relay. The bulbs are fine. Last resort is to change the switch itself which wouldn't be expensive nor difficult (I think, but it is a mini so...) but I figured I'd make a post and see if anyone knew what this could be or if anyone has encountered it before. Luckily my highbeams aren't too bright and they're pointed pretty down so when they come on in traffic they aren't too bothersome to other drivers but when they are flashing on and off as they do some times I worry about annoying others on the road so I need to get them fixed asap.
more likely body control module related as both go out would say its a control fault and and not two random faults with exons
 
1 - 3 of 3 Posts
Top