MINI Cooper Forum banner
1 - 20 of 44 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 · (Edited)
Hello,
With the previous cold mornings has anyone noticed if their needle on the speedo has went eratic for a few seconds bouncing on the stop at start up....think i need another trip to my ever so helpful dealership......i am on first name terms with every member of staff so far.....

-----Ian E-------

PURE SILVER MO, SALT PACK, 7-HOLE ALLOYS, SPORTS SEATS, TRIP COMP, LEATHER WHEEL, CHROMED UP, BODY COLOUR MIRRORS, ARMREST......:silver: :p
 

·
Registered
Joined
·
40 Posts
Yes, mine does that occasionally too just on startup. Almost as though it's shivering!!!

Be interested to hear what your dealer says.

Phil
 

·
Registered
Joined
·
512 Posts
My wife noticed my speedo needle do this once. I've never seen it myself, but according to her, it dropped suddenly then shot right back. We had been driving for ~5 minutes, and the ambient temperature was not cold, probably 60 degrees minimum. The battery light was flashing at the time, too, so they could be related. I've had the battery light flash on several occasions, but have never seen the needle jump other than that once (assuming my wife wasn't just seeing things ;) )

PigLick
 

·
Registered
Joined
·
79 Posts
Mine Too

Sounds unrelated but...I washed the MCS for the first time yesterday and when I opened the door, the speedo and fuel gauge needle were jumping. Best description is "like it was shivering". It was only when the door was open, key not in the ignition. Closed the door it stopped. Opened the door, it did it again. Started the car and moved it around to the garage. Hasn't done it since.

Dealer (as usual) says, "I don't know".

Go figure. At least it still runs.
 

·
obsessive
Joined
·
85 Posts
Yes I have experience this problem and on a daily basis.

It is like my mini has had a cold since december. Every time i start it from cold my rev needle zooms past the red line, twitches and stays there for about 5 minutes, then it starts to twitch again followed by it irratcially going from 0 reves to past the red line and back again untill it sorts its self out 20mins later.

its going in to be looked at next week and they want it for a few days so ill keeep you posted on what happens!!!! (fingers crossed)
 

·
Registered
Joined
·
558 Posts
I haven't seen the needle jump when driving, but I've noticed the speedometer needle jump when pressing the trip odometer reset button when the key is out of the ignition.

Anyone else notice this?

retroom
 

·
obsessive
Joined
·
85 Posts
got my car back and they fixed the problem

Ok i have had my mini in for the last 2 days they found thhe problem strainght away, it was a fault inside the rev counter, so they replace the whole system.

It all works fine now!! good luck the the rest of you.
 

·
Registered
Joined
·
106 Posts
Re: Mine Too

IMAXMINI said:
Sounds unrelated but...I washed the MCS for the first time yesterday and when I opened the door, the speedo and fuel gauge needle were jumping. Best description is "like it was shivering". It was only when the door was open, key not in the ignition. Closed the door it stopped. Opened the door, it did it again. Started the car and moved it around to the garage. Hasn't done it since.

Dealer (as usual) says, "I don't know".

Go figure. At least it still runs.
My MCS did the same thing this morning. I opened the door and the Speedometer needle was shaking away. Key wasn't even in the ignition. It stopped once I started the car.
My car is only two weeks old with less than 500 miles on the clock.
 

·
Gone fishing
Joined
·
413 Posts
Re: Mine Too

IMAXMINI said:
Sounds unrelated but...I washed the MCS for the first time yesterday and when I opened the door, the speedo and fuel gauge needle were jumping. Best description is "like it was shivering". It was only when the door was open, key not in the ignition. Closed the door it stopped. Opened the door, it did it again. Started the car and moved it around to the garage. Hasn't done it since.

Dealer (as usual) says, "I don't know".

Go figure. At least it still runs.
Ditto
 

·
Registered
Joined
·
32 Posts
M11NYL said:
Yes I have experience this problem and on a daily basis.

It is like my mini has had a cold since december. Every time i start it from cold my rev needle zooms past the red line, twitches and stays there for about 5 minutes, then it starts to twitch again followed by it irratcially going from 0 reves to past the red line and back again untill it sorts its self out 20mins later.

its going in to be looked at next week and they want it for a few days so ill keeep you posted on what happens!!!! (fingers crossed)
I've had the same experience. When it is cold on startup the rev counter just sits against the 0 RPM stop and 'shivers', making a rather loud buzzing noise. When driving it reads about 2000rpm short making it easier to bounce off the rev limiter :D with the stereo up LOUD!!!
It has also occasionally spent a while just bouncing around a random selection of revs with no correlation to the engine speed.

Took it into the dealers and they say it requires a new rev counter. Just need to make arrangements to book it in!
 

·
I'm a world record holder
Joined
·
229 Posts
I have had the same problems as some of you. Also I found that when I open the drivers door ofter the car had been sat for a while the needle jumps alittle.

I took it into the dealership and they have replaced the speedo. The problem only happended once and I have only had the new speedo in a couple of weeks so I dont know if it has cured it or not. Will keep you posted though.
 

·
Registered
Joined
·
71 Posts
When I got in my car this morning I heard a clicking and noticed the speedometer needle was jumping up and down between 0 and about 5 mph and clicking every time it hit zero. The gas gauge and temp gauge needles were shivering too, just not as extravagently. It stopped as soon as I started the car. First time we've seen that. Have to keep an eye on it.
 

·
Registered
Joined
·
32 Posts
Sorted

Got the car back from the dealer yesterday and they have replaced the rev counter. All seems well for now. Just need to get the sunroof seal sorted.
 

·
Blindin'
Joined
·
192 Posts
Mine used to do this. I mentioned it to the dealer at my first sevice, they had a look and said that one of the battery leads wasn't fastened as tight as it should be - they tightened it and it hasn't done it once in a couple of months! (I used to do it every couple of days)
 

·
Registered
Joined
·
182 Posts
My July 02 MCS has the shaky needle thing, dealer replaced entire speedo unit and emailed BMW Germany asking for advice, needle seems ok for now, but not heard back from dealer yet.. Will check my battery cables tomorrow....lol

Nige.
 

·
Registered
Joined
·
3 Posts
My 2004 MCS has 2100 miles on him and the strangest thing happen Tuesday. I had driven about 150 miles and stopped for the day got stuff out and locked the car, the next morning I went out to put some things in Nigel and heard a very strange clicking sound. I looked for the source of this noise and discovered my speedometer needle jumping from 0 to about 6 mph and just ticking back and forth. I do not know if it had been doing this all night or for what period of time. I got in and cranked the car up and the jumping stopped and everything seemed fine. Has anyone else had this experience? Does anyone know about it? Should I worry?
Help and THANKS.
 

·
Registered
Joined
·
412 Posts
I've not had that problem but when I start my car up up all the needles (except the rev counter) dip below zero and rattle madly against the stops. It lasts for around five seconds. One thing I have noticed though is if I go out and have a good drive (over 40 miles) it won't do it the next day, but if the car is left for more than a day afterwards then it will do it again. Basically it does it every day as I rarely drive more than 20 miles a day.


cloudr said:
My 2004 MCS has 2100 miles on him and the strangest thing happen Tuesday. I had driven about 150 miles and stopped for the day got stuff out and locked the car, the next morning I went out to put some things in Nigel and heard a very strange clicking sound. I looked for the source of this noise and discovered my speedometer needle jumping from 0 to about 6 mph and just ticking back and forth. I do not know if it had been doing this all night or for what period of time. I got in and cranked the car up and the jumping stopped and everything seemed fine. Has anyone else had this experience? Does anyone know about it? Should I worry?
Help and THANKS.
 

·
Registered
Joined
·
412 Posts
Just a quick update. Got my car back today after they've looked at the problem. They said the battery had a very low charge and asked me if I leave it for long periods with no use, which I don't, they charged it anyway so hopefully it will sort things out.

stellablade said:
I've not had that problem but when I start my car up up all the needles (except the rev counter) dip below zero and rattle madly against the stops. It lasts for around five seconds. One thing I have noticed though is if I go out and have a good drive (over 40 miles) it won't do it the next day, but if the car is left for more than a day afterwards then it will do it again. Basically it does it every day as I rarely drive more than 20 miles a day.
 

·
Registered
Joined
·
412 Posts
It didn't work. They looked at it again yesterday and they told me that lots of them do this including BMWs. So that's alright then! :rolleyes:




stellablade said:
Just a quick update. Got my car back today after they've looked at the problem. They said the battery had a very low charge and asked me if I leave it for long periods with no use, which I don't, they charged it anyway so hopefully it will sort things out.
 
1 - 20 of 44 Posts
Top