MINI Cooper Forum banner
101 - 120 of 129 Posts

·
Registered
Joined
·
10,177 Posts
Discussion Starter · #101 ·
would drive it for a few miles get it al nice and hot and repeat this over cold to hot starts then see what you have anything after thus is a fault somewhere,, bare in mind cat dont start working until gets to around 600c as do the 02 sensors , i would live data it look at coolant temps, look at smooth running and injector corrections and 02 sensor voltages on signal ie a engine run for a good hour at 3000 revs should have a 0.7volts middle value fast changing on pre cat and slower changing on post cat sensor,
 

·
Registered
Joined
·
2 Posts
would drive it for a few miles get it al nice and hot and repeat this over cold to hot starts then see what you have anything after thus is a fault somewhere,, bare in mind cat dont start working until gets to around 600c as do the 02 sensors , i would live data it look at coolant temps, look at smooth running and injector corrections and 02 sensor voltages on signal ie a engine run for a good hour at 3000 revs should have a 0.7volts middle value fast changing on pre cat and slower changing on post cat sensor,
Hi Mike it’s me Paul going change cam chain what you recommend nothing to exspensive it’s for my daughter
 

·
Registered
Joined
·
10,177 Posts
Discussion Starter · #103 ·
below link febi bilsteen ,
the vanos sprocket would ever buy genuine ones if doing them as well, at 60k would not bother at 120k deffo would do them
 

·
Registered
Joined
·
10,177 Posts
Discussion Starter · #105 ·
hi mike do you reprogram ecu after fitting cam chain reset position of vanos
i reset adaptions on any car after such work, that said sometimes I come up against something that dont give option for reset , when get that I do the the work do a power latch reset on it and then start and leave to idle until fan kicks in and off again then then take for a drive,, this should allow the ecu to rework out where it all stands as such, i seen on here coupe of people have had issues with not running right and they ended up taking to main dealers and main dealer have done a software update and cured the problems ,, but no light on what kind of update and what the update was meant to cure etc, was from a US owner and he says will fix all problems as it did his car and another guys so worth keeping in mind,
 

·
Registered
Joined
·
10,177 Posts
Discussion Starter · #109 ·
battery a bit flat or starter a bit lazy , failing that rings not put in right ie the gaps must be 180 degrees apart on oil rings and same on compression rings, maybe timing not correct , try adding oil in each cylinder just before compression test if its shots up to over 160psi then ring issue maybe hone the bores wrongly , if dont change then timing not right most likely or lapping in valves not gone right
 

·
Registered
Joined
·
2 Posts
i only seen it cos the mini guy did on you tube reset the vanos but he the only one makes sence be honest
Hi Mike still getting p0015 code
Take to mini garage and they where also getting it after adaptions
Said I could need a exhaust sprocket
What aftermarket ones you recommended
 

·
Registered
Joined
·
10,177 Posts
Discussion Starter · #113 ·
dont recommend any after market vanos sprockets must use genuine, cheapest in from Peugeot main dealers brand new £58 the last one I bought , bmw want stupid one for them and same part,
or below is genuine and is the same part i promise you
 

·
Registered
Joined
·
10,177 Posts
Discussion Starter · #117 ·
valvetronic motor is linked to car ecu if ecu detects a higher resistance from motor it will throw a default limp mode and those codes to protect it self, and shuts down the vvt and vanos system , i have had this myself after a rebuild when the concentric shaft is jammed or will not flow easy ie puts to much load on the vvt stoppa motor on the rear of head , as a motor is a dead short at start up and if cant rotate freely will cause to much resistance,,, the system does this to prevent a fire ,
vvt is the high lift for inlet valves,, vanos is timing related two different things some people get confused between them
 

·
Registered
Joined
·
40 Posts
seems 1030 and 1062 have gone hopfully a blip getting back to 10015 have you had success cleaning exhaust sporoket or do i buy another
 
101 - 120 of 129 Posts
Top