MINI Cooper Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
So... I had the car booked in for an MOT. I bought it from a neighbour but it had been sitting for sometime. I gave it a once over to check basic things and noticed the indicators do not work on the LEFT side at all, and the Front right does not work. Also noticed the rear "side" light doesnt work either(i can bodge this...) but what can I do about these indicators? I can go to the scrap yard and get another BCM but how can I be sure its the BCM?

The same issue occurs when using Hazards or Indicators.

Many thanks,
Chris
 

·
Registered
2005 Mini Cooper
Joined
·
11 Posts
Haha okay, I only said it because I had to change 3 on mine when I bought it - is anything else effected, like heaters/wipers? That would point to BCM maybe?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
They all work! How can I be sure the BCM works? I checked on Ista and it had no errors and said bulbs was fine...
 

·
Registered
2005 Mini Cooper
Joined
·
11 Posts
The first thing that came up with a search was the BC1 unit being a potential culprit - water ingress etc. on earlier models causing strange behaviours in lots of things. Might be worth investigating further? Because yeah, you'd definitely wanna be sure it's the BCM.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Just weird how the BCM controls all the lights separately and only 2 out of 6 work! Also one rear side light doesn’t work so that’s why I’m thinking BCM!
 
1 - 7 of 7 Posts
Top