MINI Cooper Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi guys

I have an r50 with no heat coming out.
I bled the system and topped up. I'm 99% sure there is no leak.

It did warm up the air a tiny bit when heating is on. Fans work fine. However I think it may be the matrix.

Do I have to take the side panel off to see if the matrix is getting hot or do you think after a long drive I could put my hand on the plastic to tell?

I'd rather not take the panel off if I don't have to .
 

·
Registered
Joined
·
62 Posts
I replaced the heater matrix this week in my 2002 R50. Symptoms were :-
  • coolant loss (slow but consistent),
  • poor heating (would kind of feel warm if the fan was low but on higher speed felt cool)
  • very damp on the inside of the windows (especially cold mornings which is why I just did it!)
  • musty smell
When I removed the old matrix, there appeared to be slight perforation around the 'shoulder' at the end where the pipes are attached. Noticeably warmer in the car now it's been replaced and the system filled and bled.

The heater matrix is right behind that plastic panel so if it's getting warm you should be able to feel it without removing the panel.
I've left the panel off mine for the time-being just to make sure there are no leaks before I put the panel back and the matrix gets too hot to touch (as you'd imagine).

I have read somewhere that in some cases, on removal, the matrix appeared OK but is clogged up so a flush was all that was required.
 

·
Registered
Joined
·
62 Posts
Also, make sure you are filling the system via the theremostat neck and are bleeding from both bleed screws - the one on the top hose and the one behind the thermostat that goes through the bulkhead to the heater matrix. Sorry if this is obvious :)
 
1 - 3 of 3 Posts
Top