MINI Cooper Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi all,

First post here, hoping for some advice if possible.

My daughter's 2007 Mini Cooper R56 model has a slight issue with an Oil Pressure Warning Light coming on when idle ..

It's only done 63,000 miles, and the camchain was replaced at 43,000 miles.

I've checked, and there is oil in the sump, and it's not losing any anywhere.

No death rattle on startup, no misfires, smells etc.

It drives lovely, but the Oil Pressure Warning Light only comes on when idle/in neutral, and after about 20 mins of driving (ie when oil is hot and thin).

Any thoughts ? I've googled and this seems to be a common problem, with various issues such as faulty sensor, faulty oil pump, bad cam-chain tensioner etc

Looking at the service history, it does need a service - so maybe a decent oil change and good quality filter is the answer ?

I appreciate it's hard to give advice, but I've got no other identifiable symptoms, other than this warning light when idle.

Cheers
 

· Registered
Joined
·
71 Posts
Get a pressure check done with a 'real' gauge - you should see 50 lbs/sq in or better once off idle.
MINIs like their oil & filter changed frequently - the recommended mileages are optimistic - 7,500 - 10,000 with full synthetic are preferable.
 

· Registered
Joined
·
437 Posts
I had similar issues with oil light flickering on idle.
Check the vvt solenoid haven't got their gauze filters covered in crud. Clean them with brake cleaner and put them back.
Front one easy enough to do back one is a bit fiddly
I Also use a genuine oil filter when I did an oil and filter change as aftermarket filters can cause issue with oil flow.
I did end up replacing my vvt solenoids in the end as the light came back on a few weeks later and seems to have cured it.
 

· Registered
Joined
·
13,595 Posts
Hi all,

First post here, hoping for some advice if possible.

My daughter's 2007 Mini Cooper R56 model has a slight issue with an Oil Pressure Warning Light coming on when idle ..

It's only done 63,000 miles, and the camchain was replaced at 43,000 miles.

I've checked, and there is oil in the sump, and it's not losing any anywhere.

No death rattle on startup, no misfires, smells etc.

It drives lovely, but the Oil Pressure Warning Light only comes on when idle/in neutral, and after about 20 mins of driving (ie when oil is hot and thin).

Any thoughts ? I've googled and this seems to be a common problem, with various issues such as faulty sensor, faulty oil pump, bad cam-chain tensioner etc

Looking at the service history, it does need a service - so maybe a decent oil change and good quality filter is the answer ?

I appreciate it's hard to give advice, but I've got no other identifiable symptoms, other than this warning light when idle.

Cheers
would check sump not been bent upwards, i ran into this the other day and spent way to much time finding it, chain event with this car was timing chain replaced a while ago and when it was done the engine mounts needs removing that means engine needs to be supported, someone had used just a jack and to bottom of sump, rather than support off driveshaft or the metal bracket,, then as oil gets worn out and filter gets iffy it all adds to the restricted flow on this one,, if sump has marks on it i would remove it and either replace it or give it a hit with a hammer where oil pick up for pump lives
 
  • Like
Reactions: Whonatic

· Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
Quick update on my original post ..

The car went into the local Mini Specialist today, for diagnostics ..

Initial diagnostics threw nothing up, so they removed the sump and checked for engine debris in the oil.

That was all clear, so they carried out an oil and filter change. The old filter was (in their words) pretty gummed up ..

The Oil Pressure Switch was also replaced as it had a very slight leak ..

But, no identifiable problems with the Oil Pump or Camchain / tensioner - phew.

One bill for £263 later and so far (touch wood) no oil pressure warning light.

?
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top