MINI Cooper Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter · #1 ·
Hey all.

I've recently developed a problem with my braking. When Im going at fast speeds and need to slam my foot on the brake.. I get a grinding sort of feeling.. like something is stuck between the pads.

It actually feels like the pedal is rubbing against the ground! Only happens sometimes.

Anyone had a similar experience??
 

·
Registered
Joined
·
37 Posts
My wifes cooper was doing similar, new front discs and pads and the rears looked a bit low but still enough on them not to be causing any problems.

however, only this morning, i took the wheel off the rear wheel the sound seemed to coming from and on closer inspection on the pad on the back side of the disk (which you cannot see with the wheel on) was noticably lower than the pad on the front of the disk. I removed the caliper and found the back pad to be down to the metal:aargh:

Just be careful, i was surprised how it was compired to the one you can easily see, in fact the other rear wheel was no where near as bad. I imagine i must hade a bit of brake binding on that side.

Hope you get it sorted
 

·
Where does that road go?
Joined
·
12,574 Posts
I've recently developed a problem with my braking. When Im going at fast speeds and need to slam my foot on the brake.. I get a grinding sort of feeling.. like something is stuck between the pads
Is it the ABS kicking in? Kinda like a juddery pedal? Just a thought
Have to agree, it sounds like the ABS kicking in :smile:
I also have to agree. :)

If it is the ABS kicking in, and you're experiencing this a lot, it's time to slow down. ;)
 

·
Registered
Joined
·
80 Posts
Discussion Starter · #9 ·
I thought it might be the ABS aswell.. but the feeling was much different to what I thought it would be! It wasnt even a juddery feel.. it was more of a 'damn.. it feels like im grinding metal' feel!.

I think I'll make most of the KwikFit free brake check and get the rears checked out!!

Thanks alot guys!
 

·
Registered
Joined
·
325 Posts
I'd get it checked quick because if it is the rears then you be in for a new set of rear discs as well :)

MAFFA
 

·
Mini Torque
Joined
·
2,033 Posts
could even be a faulty speed sensor i had the local garage do my brakes once and they mess up the speed sensor on the hub and caused a similar issue
 
1 - 11 of 11 Posts
Top