MINI Cooper Forum banner
1 - 7 of 7 Posts

·
Mr Buttons!
Joined
·
837 Posts
Discussion Starter · #1 ·
Hi all,
I've had my Milltek cat-back exhaust on for about three weeks now. When I was driving last week, I noticed a loud, harsh sound coming outof the exhaust upon acceleration in the 1-3K rpm range. I think this is only happening when the weather is cold(30 degrees F), but it sounds awful. It's extremely loud, and makes me sound like I have a coffee can muffler. After 3K, it goes away. Has anyone had this problem? Does anyone know how to fix it? I looked under the car, but couldn't find anything wrong. Also, I do have the aero kit, and my suspicion is that the rear bumper(which rubs against the exhaust is rattling due to exceswsive vibration. But the sound is way too loud for just vibration, so I dunno... :(
 

·
Registered
Joined
·
60 Posts
Johnny -
Although my Milltek has been on for longer than yours I've also started hearing a loud "vibration" noise coming from the rear of the car. Mine only happens during WOT and at a higher RPM (around 3800 ~4000).
I was going to crawl under the car this weekend and see if I can figure it out. I also think the sound is coming from the rear panel vibrating against the exhaust.
Let me know what you find out.

Tim
 

·
Registered
Joined
·
76 Posts
I also have the miltek header and cat with a JCW exhuast - if you have the areo kit (early one) there is brace at the rear which was added later in the release of the aero kit -check to see if you have this brace - it could be the problem.....



Johnny225 said:
Hi all,
I've had my Milltek cat-back exhaust on for about three weeks now. When I was driving last week, I noticed a loud, harsh sound coming outof the exhaust upon acceleration in the 1-3K rpm range. I think this is only happening when the weather is cold(30 degrees F), but it sounds awful. It's extremely loud, and makes me sound like I have a coffee can muffler. After 3K, it goes away. Has anyone had this problem? Does anyone know how to fix it? I looked under the car, but couldn't find anything wrong. Also, I do have the aero kit, and my suspicion is that the rear bumper(which rubs against the exhaust is rattling due to exceswsive vibration. But the sound is way too loud for just vibration, so I dunno... :(
 

·
Registered
Joined
·
1,070 Posts
rb905678 said:
I also have the miltek header and cat with a JCW exhuast - if you have the areo kit (early one) there is brace at the rear which was added later in the release of the aero kit -check to see if you have this brace - it could be the problem.....
That was the problem with mine, just had a rear centre bracket fitted to my aero kit :cool:

Now no rattles at all :D
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top