MINI Cooper Forum banner
1 - 9 of 9 Posts

· Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey, bit of an issue. Having issues starting the car. This has only started over the last couple of weeks. Basically when it turn the ignition, all the lights are on then I try and start it, nothing, not even a click. Took it to a garage thinking it was the starter motor but they did a diagnostic and it said that it was working fine. He did say that the battery was fine although it needed a charge. He also said that the connections were loose and a overnight charge would hopefully sort it.
Turned it over this morning and it worked fine, went to the stop it started fine and got home. Going out again and it's doing the same again and not working. I need help and I just have got the funds to pay for a starter motor if it doesn't need it. This is my first mini and only had it 6 months, so new to this game. Thanks
 

· Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Yeah checked that and they are tight. Now 1 thing I have done (that doesn't make sense) is remove the black plastic battery cover and its started working again. But its done that before after shutting the bonnet.
 

· Registered
Joined
·
13 Posts
Hey, bit of an issue. Having issues starting the car. This has only started over the last couple of weeks. Basically when it turn the ignition, all the lights are on then I try and start it, nothing, not even a click. Took it to a garage thinking it was the starter motor but they did a diagnostic and it said that it was working fine. He did say that the battery was fine although it needed a charge. He also said that the connections were loose and a overnight charge would hopefully sort it.
Turned it over this morning and it worked fine, went to the stop it started fine and got home. Going out again and it's doing the same again and not working. I need help and I just have got the funds to pay for a starter motor if it doesn't need it. This is my first mini and only had it 6 months, so new to this game. Thanks

I had exactly the same on my R52, like you, I thought it was the starter motor, or possibly the battery...

But turned out to be the "Ignition switch" and that's Not the bit where you put your key in... it's the actual ignition switch in the opposite side of the steering column. They cost from £100 at a main dealer, to around £40/£50 for an aftermarket new one, but if you go on ebay, you can find several used 'Mini Cooper ignition switch' listings. I bought one for £10.95

I found a Youtube clip that shows you how to change it:


I didn't find it too difficult, the main thing is to have the right torq screw driver to get the covers off the steering column. It took me about an hour and all fine since.

Why not take a look at the Youtube clip and decide if it's something you feel you can do yourself.

Good Luck !!
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top