MINI Cooper Forum banner
1 - 20 of 84 Posts

·
Registered
Mini Cooper S 2011 (R56 N18). Mini One 2012 (R56 N16).
Joined
·
203 Posts
Discussion Starter · #1 ·
Good afternnon illustrious Mini officianados.

Was out for a drive this afternoon when the half engine/limp mode light came on accompanied by loss of power. :cry:

I pulled over and switched the car off for a few minutes. On restarting light was off and power returned.:)

I am wondering if this could be related to something I noticed when poking around under the bonnet the other day.

After a drive (to pick up oil for a top up) I noticed a slight hissing noise coming form the joint pictured below. Looks like it has been (badly) repaired with some sort of glue?

282231
282233


Could this be the cause of my engine light?
Any idea what part I should be looking for to replace it? Turbo air intake pipe?

Any advice you can offer would be much appreciated.
 

·
Registered
Joined
·
10,511 Posts
scanners like not worth the hassle, need something like wow wurth snooper or autocom cdp plus google them will come with links to buy them under £50 , easy to use once installed
 

·
Registered
Mini Cooper S 2011 (R56 N18). Mini One 2012 (R56 N16).
Joined
·
203 Posts
Discussion Starter · #9 · (Edited)
So, ended up going with the Forge motorsport pipe.
Next day delivery, arrived this morning. Fitted in about 10 minutes.
The old glued pipe fell apart as I removed it, glue had gone all chrystaline, definately wasnt sealing.

282277


Twice the price of the MTC and Imperial versions but concerned over their quality.
Quick road test and all seems well. Seems to be running a bit smoother. Hard to say.
 

·
Registered
Mini Cooper S 2011 (R56 N18). Mini One 2012 (R56 N16).
Joined
·
203 Posts
Discussion Starter · #11 · (Edited)
Update - Limp mode engaged on a spirited drive this morning. Pulled over lifted bonnet, had a poke, nothing obvious amiss apart from bubbling noise from turbo area (hard to nail down as was in very noisy layby on dual carriageway). Started off again, still in limp mode for about 5 miles then suddenly back to normal. Then about 5 miles later oil can symbol flashed up on Tacho and was gone. Car drove as normal the rest of ther way home. Waiting for Autocom cdp plus to arrive (have sent crappy Akface obd2 scanner back to Amazon). Pretty vague without codes I know, but was just wondering if anybody might have any ideas whats going on.
 

·
Registered
Joined
·
10,511 Posts
check oil level when they run low they will run all crap or the oil its self seems some oil dont go well with the over hot prince engines ,, if bubbling noise around turbo you should hear a pump pumping water around if cant that could be the issue aux water pump failed ie its a 12v water pump pushes water through turbo mainly ,, when fail they can effect how hot engine oil gets as turbo gets super hot without it,
 

·
Registered
Mini Cooper S 2011 (R56 N18). Mini One 2012 (R56 N16).
Joined
·
203 Posts
Discussion Starter · #14 ·
Thanks for the reply mike1967. Much appreciated.

Oil level is checked and topped up (if necessary) weekly. It has used slightly less than 1 liter in last month (approx 800 miles).
Changing oil and filter on friday as not sure when it was last changed. Waiting for Seafoam to turn up.

Aux water pump makes perfect sense (not that I knew it existed). Will check it out.
 

·
Registered
Joined
·
10,511 Posts
Thanks for the reply mike1967. Much appreciated.

Oil level is checked and topped up (if necessary) weekly. It has used slightly less than 1 liter in last month (approx 800 miles).
Changing oil and filter on friday as not sure when it was last changed. Waiting for Seafoam to turn up.

Aux water pump makes perfect sense (not that I knew it existed). Will check it out.
that aux pump if take car for a run and get it to 105c running temps then shut car down and open the bonnet you should hear a whirring noise from under the turbo,, that said i have seen them make the noises and find the impeller has snapped off the motor shaft before with age and heat,
below link is brand new one prob a bit cheaper than what bmw want as its a psa one but are the same thing and fit plug and play
 

·
Registered
Mini Cooper S 2011 (R56 N18). Mini One 2012 (R56 N16).
Joined
·
203 Posts
Discussion Starter · #17 ·
take car for a run and get it to 105c running temps then shut car down and open the bonnet you should hear a whirring noise from under the turbo
Will do exactly that.
Again. Thanks for your input Mike and taking time to help us novices. You are hugely appreciated.
 

·
Registered
Mini Cooper S 2011 (R56 N18). Mini One 2012 (R56 N16).
Joined
·
203 Posts
Discussion Starter · #18 ·
So. Took for a drive, got up to about 102c pulled over in a quiet spot and popped bonnet. Definate pump sound from underneath turbo. On the way home I stupidly put my foot down a bit and limp mode engaged and has stayed on this time. Let the car cool for a couple of hours and fired it up on the drive, runs ok but limp mode still on.
 

·
Registered
Joined
·
10,511 Posts
So. Took for a drive, got up to about 102c pulled over in a quiet spot and popped bonnet. Definate pump sound from underneath turbo. On the way home I stupidly put my foot down a bit and limp mode engaged and has stayed on this time. Let the car cool for a couple of hours and fired it up on the drive, runs ok but limp mode still on.
you need to scan it live data etc like i keep telling people on here cant beat autocom cdp plus will pay for its self the first time you use it and really is that good garage level, need to know what the codes are for a start
link below for autocom cdp plus
 
1 - 20 of 84 Posts
Top