MINI Cooper Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I just replaced my thermostat and thermostat housing, and prior to beginning the job I disconnected the battery since the ECU had to be unplugged and removed
for access. The thermostat job went well, but when I re-connected the battery the factory radio says "Disable" on the screen. This is a 2003 model S, so it shouldn't
require a code. I do have the radio card with the code on it if needed.
I checked the 5 amp fuse in the fuse panel for the radio and it was fine. I assumed it was since I was getting power to the unit.
Does anyone have any suggestions on how to get the radio back up and running?
Thanks in advance.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
I found the problem. When I pulled the radio out, there was a wire that had become disconnected. I assumed it was the control wire, so I re-connected it and that solved the problem.
The story behind this radio is that when I bought the car a few months ago, it had a Sony head unit in it with an amp in the hatch area. The head unit didn't fit all the way in as there were RCA plugs that stuck out of the back of the unit.
I wanted the original look back, so I got lucky and found one at pick-n-pull from a 2003 model like mine.
I had to re-do all the wiring back to original because whoever installed the Sony unit had spliced into the original wiring to adapt the unit.
After all that, the radio worked first time and had for months. What I suspect is that the radio received the correct signal on initial startup, but between then and now the wire came loose. When I disconnected the battery to do the thermostat housing replacement it did not get the signal and went into disable mode. Once the wire was fixed, it got the correct signal and is now working.
Hope this helps someone in the future.
 
1 - 2 of 2 Posts
Top