MINI Cooper Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
Hey All

I picked up my MCS last week and i cant get the rear washer to work? It was working on friday when i drove down to Cornwall but now its stopped working and yes I have filled it right up with water (both front and rear resevoirs).

Any ideas?

Cheers
 

·
T o t a l m i n i . c o m
Joined
·
4,467 Posts
and also after me and Ian fixed mine the other day, where the jet is, it hinges of to the side and you can check the feed also;):D
 

·
T o t a l m i n i . c o m
Joined
·
4,467 Posts
Basically where the washer jet is, it's on a seperate bit of plastic along side the wiper blade- it just hinges to the side and then there is a metal feed which you can also check isn't blocked. I'll try and post a pic tomorrow when it is light;)
 

·
Registered
Joined
·
21,966 Posts
Basically where the washer jet is, it's on a seperate bit of plastic along side the wiper blade- it just hinges to the side and then there is a metal feed which you can also check isn't blocked. I'll try and post a pic tomorrow when it is light;)
just don't drop the pin in it :eek::p
 

·
Registered
Joined
·
44 Posts
Discussion Starter #10
I cant see this part that attaches!? I can see what looks like a washer built into the body where it joins the rotor that moves the blade? Anyone got a picture of this?
 

·
T o t a l m i n i . c o m
Joined
·
4,467 Posts
Finally got the camera out today:D:D

Hope this is some help:D

When you have the piece open, check to see if water comes out the nozzle. If it does then the plastic jet is blocked:D If not then it is proberly the pipe or something:(
 

Attachments

·
Registered
Joined
·
9 Posts
you can just take off your nozzle off first, just beside the blade, than try to see any water come through the jet, if water does can shoot out from the jet, than try to use a needle to unblock the nozzle, remember to block both side of the hole, if it is too dusty, I recommend put the nozzle into the water for about 1 or two hours, than try to unblock it.

Hope this helps
 

·
Registered
Joined
·
44 Posts
Discussion Starter #16
It turns out i need a new unit (the bit that folds out) as the rubber grommet had perished so water wasn't being fed into the unti to spray. I want to just get the grommet part but they said I couldn't - any thought?
 

·
JcwMiniAdventures
Joined
·
434 Posts
May be a long shot & you may have already tried/not that fault but i have just had the same problem where my front works but rear doesn't. I replaced the washer pump to no avail then tried the suggestion in post 12 of the relay & nearlly £6.40 ligheter & a new relay i know have a rear washer again

Worth looking into??
 
1 - 18 of 18 Posts
Top